cancel
Showing results for 
Search instead for 
Did you mean: 

General Discussions

pulsefxre22
Adept I

Problems with Windows 10 Ver. 2004 Update + Radeon Adrenalin 20.5.1 / Vega 56 OC / AMD Ryzen 5 2600

Hello everyone,

after about 5 hours I finally got my system running almost perfect again. I want to share a bad experience with all of you and maybe help out some individuals.

I updated my windows 10 64-bit to the newest version 2004. After that my radeon software didn't do it's job right. It all was a mess. I thought why not update it from the installed 20.2.2 to the newly released 20.5.1 drivers then. It was a bad idea. First of all the windows update messed up my whole desktop and all graphic settings, which was really annoying on its own but it got worse.

After I adjusted everything back to where it was I updated the amd drivers. I currently have an AMD Radeon RX Vega 56 (Sapphire Pulse) with OC and an AMD Ryzen 5 2600 (Stock). One of my monitors is running with VSR (Virtual Super Resolution) on WQHD (1440p). Everything seemed to be okay until I started a game. The CPU went up to 90-100% usage for no reason. The image was stuttering and flickering very bad. So I decided to get back to the drivers 20.2.2 which are the best drivers for a long time when using a Vega 56 with OC in my opinion. They are very stable and it just works. I uninstalled all the drivers and monitors with DDU to make sure everything is clean for the installation of the radeon 20.2.2 software and drivers. Before that I installed the monitor drivers, thats's very important to do first! Everything worked fine after that but the CPU usage is still a bit too high in my opinion but it's mostly below 50% on games with high/ultra settings in 1440p which is okay.

Conclusion:

If you have an AMD Radeon RX Vega 56 with an overclocking profile you should wait with the windows 10 64-bit ver. 2004 update because it might mess up a lot. If you want to update your windows anyways you should uninstall the amd drivers with DDU and clean install them again after all the windows updates to avoid any problems. And don't forget to save your Wattman profiles and Radeon settings in general. I forgot it and had to redo everything.

Best Radeon Version for Vega 56 OC (Overclocking):

  • Radeon Adrenalin 2020 Ver. 20.2.2

Where to get DDU for uninstalling the drivers?

Where to get Radeon 20.2.2 drivers for Win10 & Win7 64-Bit?

My current setup:

  • Case: Sharkoon TG5 RGB
  • GPU: Sapphire Pulse RX Vega 56 (Wattman OC/UV)
  • CPU: AMD Ryzen 5 2600 (Stock)
  • MB: ASUS ROG Strix B450-F Gaming
  • RAM: Corsair Vengeance RGB PRO 16GB, DDR4-3200 CL16 DK
  • AiO: Corsair H100i RGB PLATINUM
  • FANS: Corsair ML120 PRO RGB (5x)
  • PSU: bequiet! Pure Power 11 600W CM

I hope this helped someone out 🙂

Have a good day!

Manuel / pulsefxre22

4 Replies
alkalineknight
Adept II

Re: Problems with Windows 10 Ver. 2004 Update + Radeon Adrenalin 20.5.1 / Vega 56 OC / AMD Ryzen 5 2600

Hi Manuel / pulsefxre22,

Would you be able to share what the clock speeds of your CPU were recorded at. As I have a slightly different setup but am going to try what you have outlined above to see if it fixes my issue.

Mine is that my RX Vega 56 is connected as an eGPU via Thunderbolt 3 and whenever my eGPU is connected my Intel 8th Gen CPU lowers its clock speeds to the lowest possible for my CPU (0.40Ghz) which means using my machine is painful let alone the idea of loading a game.

Regards,

James / AlkalineKnight

0 Kudos
pulsefxre22
Adept I

Re: Problems with Windows 10 Ver. 2004 Update + Radeon Adrenalin 20.5.1 / Vega 56 OC / AMD Ryzen 5 2600

Hey alkalineknight,

unfortunately I can't tell you which clock speeds my cpu had when this 100% cpu usage issue appeared. I know I should have looked it up but I was kinda pissed because I knew everything was working fine before so I just reset my drivers and it worked as good as before.

What could have been a problem as well were the amd chipset drivers. As I tested something out with the Ryzen Master I realised the AMD Balanced profile in the windows settings was missing after the windows 10 update. Asus doesn't provide the newest drivers so I downloaded them directly from the AMD website. This changed nothing about the in game performance or CPU usage but the EDC is kept between 99% and 100% so the CPU doesn't drop the clock speeds when in idle. Maybe something like this is happening with your Intel CPU?

Hope I could help 🙂

Regards

Manuel / pulsefxre22

0 Kudos
alkalineknight
Adept II

Re: Problems with Windows 10 Ver. 2004 Update + Radeon Adrenalin 20.5.1 / Vega 56 OC / AMD Ryzen 5 2600

Hi Manuel / pulsefxre22,

Thank you for replying. My issue is possibly related to the AMD Xconnect Technology playing with the Intel CPU Power management settings. I have not the means of proving it atm, but I have been racking my brain for weeks.

I eventually stumbled across and installed Intel XTU. It reported that my system's Turbo Boost Power Max is equal to 3W which means none of my processors could go beyond 0.40Ghz due to Power Limit Throttling.

I managed to used the utility to set it to 30W. So far I have yet to find the actual automated fix. At this present moment in time. I have to log in and patiently load Intel XTU. Once it loads I set my Turbo Boost Power Max to 30.25W apply then back to 30W then apply. This gets it to kick in.

Though I also match this on my Turbo Boost Short Power Max (Not really required but this keeps my Laptop from going beyond 90 Degrees Celsius). It may not be a 100% fix but its a work around, and I can actually use my system.

regards,

James

alkalineknight
Adept II

Re: Problems with Windows 10 Ver. 2004 Update + Radeon Adrenalin 20.5.1 / Vega 56 OC / AMD Ryzen 5 2600

Just a link to my other thread should anyone suffer the same issue and me and wish for a workaround.

https://community.amd.com/thread/254799 

0 Kudos