Showing results for 
Search instead for 
Did you mean: 

General Discussions


New system underperforming?

Hi, I just got myself a new system but something doesn't feel right, in some games it just stutters all the time, in others it doesn't feel as smooth as my previous rig. I'll post all the info I can below.

Note: I've tried multiple solutions to figure out what's wrong. Benchmarks, drivers of all kinds, even formatting the PC. When formatting , it did become as smooth as it could , though the FPS weren't as high as they should compared to youtube videos I saw.

  • AMD Graphics Card
    • Sapphire Radeon RX 580 Nitro+ Limited Edition 8 GB
  • Desktop or Laptop System
    • Desktop
  • Operating System
    • Windows 10 64bit
  • Driver version installed
    • Radeon 18.12.2
  • Display Devices
    • Optix G27C2 1920x1080 144hz
    • (used to have a 2nd one plugged in, but with the new system it just turns on and off every second)
  • Motherboard + Bios Revision
    • B450M S2H - Version F2
    • Ryzen 5 2600
  • Power Supply Unit  Make, Model & Wattage
    • Seasonic M12 II Bronze Evo Edition
  • RAM
    • 16 GB DDR4 2400

Like I said, FPS are just stupid unstable and it doesn't feel smooth unless they go over 144fps for obvious reasons. In fortnite (I know, I just needed to test it for the sake of it , epic textures, it reached the FPS it was supposed to but quickly derailed into 20-30-40 fps , then onto 100's again and it just stuttered every second or so.

  • I've got this screenshot attached of the wattman graph during a game of overwatch. Hope it helps and thank you so much in advance!
10 Replies

Aren't you using Profiles to set the game graphics? Game profiles override Global settings. Is your Power Limit set to +50 (or the highest + value) ?

AMD graphics performance


Hello again, thank you so much for the time to answer, sorry for the delay on the reply but I've been away for a few days.

In the meantime I've gotten 3000MHz ddr4 ram as well . And no, I've deleted the OW profile, boosted the power limit to 20% since it was at 0 (20 is the limit on my card) and still nothing changes. I've tried both methods that were linked on the post you suggested as well. Still, no improvements. I've got no idea what else to try.

PS: New rams I've got :  RAM G.SKILL Ripjaws V 16GB (2x8GB) DDR4-3000MHz CL15


Do you have the computer power plan set to 'Performance'? (the default is 'Balanced')

When you installed the drivers, did you select "AMD User Experience Program"? It's easy to do as it is selected by default. Check in the Wattman panel, if it is selected...choose to quit it.


It is on the Performance Plan yes.  And I've just quit it as I was on the program.

If any possible improvements were expected, nothing happened.


Reboot after you quit the program..


Sorry, forgot to mention I did reboot beforehand


This is going to sound bizarre... but I have a suspicion as to the cause.

Do you have Access to a Controller (PS4 / Xbox 360 / Xbox One)., which you can connect to your PC?

Try using that in Fortnite and other games you're experiencing Frame Drops and let me know if the problem persists...


Is ps3 ok? Elsewise I can get my hands on a ps4 tomorrow and get back to you . Thanks in advance!

Adept II

If you get weird stutter in games you should try my project mercury tool and enable " NO CCX switching"

People have experince up to a 23% raw FPS boost and a lot less stutter on ryzen platform

Serious performance boost on Ryzen with Project Mercury : BattleRite


You can also find it on majorgeeks and softpedia if you prefer er more well known source.

also if you have a realtek audio chip make sure wavemaxaudio service is disabled


Update: After a full format and installation of step by step drivers of chipsets and whatnot, the computer seemed to show stability with only signs of underperforming BUT with no BSOD. As I powered up the power % to 50% on the Radeon WattMan, it began again, or so I Think that's what caused it. I'm leaving a dump attached which hopefully will help out figure out what the hell is happening to those who can 'read' them.

PS: I tested my memories, I had a lot of errors. after cleaning the slots, they all went away and after that format is when the PC ran fine for a bit. 

Thank you in advance, once again.

Edit: Just had another BSOD, this time not the memory management error. It was IRQL Not less or equal.