Showing results for 
Search instead for 
Did you mean: 

General Discussions

Adept I

Keep getting a media driver is missing

I’m new to this have just built my first pc but have only come across one issue and that’s when I try to download windows from my flash drive it just comes up with a media driver your computer needs is missing anyone know what I should do I’m really struggling I’ve been trying everything i can see online but nothing seems to work for me 

8 Replies

You need to go into your Bios, press F8 (or w.e your specific bios options directs you to do to get to the media device options), change boot order to your USB first.

You should also be able to select it by spamming F8 when you first power on your computer to change it for that one boot

14900k • Z790 Apex Encore • 4090 • 2x24Gb-8000 • 1200 Corsair Shift • 420mm Arctic II Push-Pull • Noctua • Fractal Torrent •

Just done that there but when I get to the windows setup it still comes up with media drivers missing


did you ever initialize the drive you're trying to install windows on in Computer Management?



14900k • Z790 Apex Encore • 4090 • 2x24Gb-8000 • 1200 Corsair Shift • 420mm Arctic II Push-Pull • Noctua • Fractal Torrent •

no I haven’t done that do I have to put the flash drive into my laptop to access that or can I access that from my new pc (without windows)


hello. i got the same issue. let me enlighten:


laptop lenovo ideapad 3 15alc6, amd processor with graphics, mobile 5500u, samsung nvme ssd

triple boot, manjaro, zorin, windows 10 1809

i have already deleted oem partition a long time ago and it's fine

then i deleted zorin partition

(i can't remember when i deleted it, something i did that caused windows to not boot(cannot be repaired, restored)

on manjaro:

then i deleted windows 10 partition, the microsoft basic partition, the recovery partition and efi boot partition

turned off laptop to install windows 10, media driver missing issue

turn on to boot to manjaro, fail

stuck on boot menu(no options work other than uefi firmware settings(bios))

oh btw my laptop is uefi class 3, so legacy could not be chosen even after switching boot mode to setup(secure boot off) as boot mode: uefi is still grayed out

boot list not a problem

no such thing as switching between sata or ide or whatsoever

no array thingy

i tried lenovo recovery media(windows 11), same issue

i only came across this section after all those so i haven't tried opening cmd terminal on windows 10 installation(shift f10 doesn't work on lenovo media)


after reading your replies, does hard drives need to be allocated first before installing windows?(as stated 'initiate') because i didn't allocate after deleting the partitions


(note* by terminal, I mean command prompt, it's just what they call the newer version on Windows 11)

mmm you should be able to do it without Windows, by accessing the terminal, going to Diskpart, listing the disks, selecting the new one, then initializing it there.

The issue is that they (windows) are making it harder and harder to access the Terminal when you're installing because there are ways to get around having to log into Microsoft when installing there which they don't want people to be able to do. (Windows 11) as long as you are installing Windows 10 though you get to the terminal by pressing 

How to Open CMD (Command Prompt) at Boot Screen in Windows 10 (

How to Initialize the Disk in Windows 11 - YouTube

14900k • Z790 Apex Encore • 4090 • 2x24Gb-8000 • 1200 Corsair Shift • 420mm Arctic II Push-Pull • Noctua • Fractal Torrent •
Journeyman III

Hi I was wondering If you got it to work somehow I am having precisely the EXACT SAME issue and I do not know how to make the driver come up, do I have to buy a hard drive ? I did every thing from downloading drivers to cleaning numerous USBs etc . HELP ME PLEASE I JUST WANNA PLAY VIDEO GAMES 

Journeyman III

The error message you're encountering, "A media driver your computer needs is missing," typically occurs during the Windows installation process, and it can be frustrating. This error can have several potential causes, and I'll provide you with steps to troubleshoot and hopefully resolve the issue:

1. **Check Your Installation Media:**
Ensure that the flash drive containing the Windows installation files is functioning correctly. Try using a different USB port or creating a new bootable USB drive using the Windows Media Creation Tool to eliminate any potential issues with the installation media.

2. **USB Port and BIOS Settings:**
Sometimes, USB ports can be the source of this problem. Try using a different USB port on your motherboard. Additionally, access your computer's BIOS settings (usually by pressing a key like F2, Del, or F12 during boot) and look for settings related to USB. Make sure USB Legacy Support is enabled.

3. **Check for USB 2.0 vs. USB 3.0/3.1:**
Some older motherboards may have compatibility issues with USB 3.0 or 3.1 ports during Windows installation. If your motherboard has both USB 2.0 and USB 3.0/3.1 ports, try using a USB 2.0 port for the installation.

4. **Change Boot Mode:**
In the BIOS settings, check the boot mode. Try switching between UEFI and Legacy/CSM boot modes to see if one works. Some systems may require UEFI mode for Windows 10 or later versions.

5. **Check for Hardware Issues:**
Ensure that your hardware components are properly connected. Loose cables or improperly seated RAM, CPU, or storage devices can cause installation issues.

6. **Update BIOS and Drivers:**
Make sure your motherboard's BIOS is up to date. Sometimes, manufacturers release BIOS updates to address compatibility issues. Additionally, update motherboard and chipset drivers to their latest versions.

7. **Check the USB Drive Format:**
Ensure that the USB drive is formatted correctly. It should be formatted as FAT32 for UEFI boot or NTFS for Legacy boot. Use the Windows Media Creation Tool to format the drive correctly.

8. **Try a Different USB Drive:**
If possible, try a different USB drive to see if the issue persists. Some USB drives may not be compatible with certain systems.

9. **Disable Secure Boot:**
In BIOS settings, you can try disabling Secure Boot temporarily during installation. Secure Boot can sometimes prevent the installation of unsigned drivers.

10. **Use Different Installation Media:**
If none of the above steps work, consider creating installation media using a different computer or downloading the Windows ISO from the official Microsoft website.

11. **Seek Professional Help:**
If you've tried all the above steps and the issue still persists, it might be worth consulting with a professional technician or the manufacturer of your PC components for further assistance.

Remember to back up your important data before making any significant changes to your system settings or attempting to reinstall Windows.