cancel
Showing results for 
Search instead for 
Did you mean: 

General Discussions

Shiellsyboy
Adept I

Keep getting a media driver is missing

I’m new to this have just built my first pc but have only come across one issue and that’s when I try to download windows from my flash drive it just comes up with a media driver your computer needs is missing anyone know what I should do I’m really struggling I’ve been trying everything i can see online but nothing seems to work for me 

6 Replies
Justifier
Challenger

You need to go into your Bios, press F8 (or w.e your specific bios options directs you to do to get to the media device options), change boot order to your USB first.

You should also be able to select it by spamming F8 when you first power on your computer to change it for that one boot

13900k • Z790 Aorus Master • 6900xt • 32gb C34, 7200 • 850 W PSU • 420mm Arctic II AIO • Noctua • GEO-M8-COW • Guilded.gg/justifiers
0 Likes

Just done that there but when I get to the windows setup it still comes up with media drivers missing

0 Likes
Justifier
Challenger

did you ever initialize the drive you're trying to install windows on in Computer Management?

Justifier_0-1660016337763.png

 

13900k • Z790 Aorus Master • 6900xt • 32gb C34, 7200 • 850 W PSU • 420mm Arctic II AIO • Noctua • GEO-M8-COW • Guilded.gg/justifiers
0 Likes

no I haven’t done that do I have to put the flash drive into my laptop to access that or can I access that from my new pc (without windows)

0 Likes

hello. i got the same issue. let me enlighten:

 

laptop lenovo ideapad 3 15alc6, amd processor with graphics, mobile 5500u, samsung nvme ssd

triple boot, manjaro, zorin, windows 10 1809

i have already deleted oem partition a long time ago and it's fine

then i deleted zorin partition

(i can't remember when i deleted it, something i did that caused windows to not boot(cannot be repaired, restored)

on manjaro:

then i deleted windows 10 partition, the microsoft basic partition, the recovery partition and efi boot partition

turned off laptop to install windows 10, media driver missing issue

turn on to boot to manjaro, fail

stuck on boot menu(no options work other than uefi firmware settings(bios))

oh btw my laptop is uefi class 3, so legacy could not be chosen even after switching boot mode to setup(secure boot off) as boot mode: uefi is still grayed out

boot list not a problem

no such thing as switching between sata or ide or whatsoever

no array thingy

i tried lenovo recovery media(windows 11), same issue

i only came across this section after all those so i haven't tried opening cmd terminal on windows 10 installation(shift f10 doesn't work on lenovo media)

 

after reading your replies, does hard drives need to be allocated first before installing windows?(as stated 'initiate') because i didn't allocate after deleting the partitions

0 Likes
Justifier
Challenger

(note* by terminal, I mean command prompt, it's just what they call the newer version on Windows 11)

mmm you should be able to do it without Windows, by accessing the terminal, going to Diskpart, listing the disks, selecting the new one, then initializing it there.

The issue is that they (windows) are making it harder and harder to access the Terminal when you're installing because there are ways to get around having to log into Microsoft when installing there which they don't want people to be able to do. (Windows 11) as long as you are installing Windows 10 though you get to the terminal by pressing 

How to Open CMD (Command Prompt) at Boot Screen in Windows 10 (techviral.net)

How to Initialize the Disk in Windows 11 - YouTube

13900k • Z790 Aorus Master • 6900xt • 32gb C34, 7200 • 850 W PSU • 420mm Arctic II AIO • Noctua • GEO-M8-COW • Guilded.gg/justifiers
0 Likes