Showing results for 
Search instead for 
Did you mean: 

General Discussions

Adept I

Cannot boot new build


I have tried to update my 7 year old tower with the new AMD processor. Nothing was wrong with the old system, just wanted to upgrade. Everything was working fine at the time of upgrade.

Removed the old 3rd gen intel CPU with ASUS MB, as well as SDD and RAM. Kept the tower and PSU.


Old CoolerMaster case

Old Thermaltake 850W PSU

New ASRock x750 phantom gaming 4 AMD

Ryzen 3700x

Corsair Vengeance LPX DDR4 3200 16GB x 2

WD 500GB black NVMe


Put together by a friend who does this work quite a bit, pretty experienced.


Powers on, fans on, graphics card fan on, two red LED lights on MB light up (CPU and DRAM), shuts off after 15 sec, then back on after a few seconds, then off again. No power to the keyboard or mouth (both USB). No signal to the monitor connected to the card directly via VGA. The VGA and BOOT lights are off.


Waited for 5-6 min, but no change. Keeps cycling

Tried each RAM module individually in every slot. No change. Made sure the RAM is tightly fit.

PS does not have external 115/230 switch. It was not touched during the upgrade.


Have a friend who uses the same CPU with MSI x750 MB and the same RAM modules without any issues. Also DIY project.  That is why I chose the Corsair RAM.


Wonder what the next step might be.  Still within 2 weeks return window. Any help is appreciated.