Showing results for 
Search instead for 
Did you mean: 

Gaming Discussions

Adept I

New Graphic cards problem

Hi guys, I recently bought the XFX RX 590 Fat Boy graphics card, everything goes well at first, I add the card to the pc, I uninstall my Nvidia drivers, I install the AMD drivers, I try to play games, at first everything goes well. But after i have tested it on other games, I notice that after 2-3 minutes on certain games, i finish having a black screen on both screens, and 2 times on 3 I am forced to restart the pc. After 3-4 days, I do lots of manipulation as well as reinstallation of drivers in factory mode, but it doesn't do anything, the problem persists. So I guess the graphics card was malfunctioning, so I sent it back and buy another one, in the meantime I was reusing my 1050 from Nvidia. I get the new card,  I install it and I do the same manipulations, I replay certain games and for my great misfortune, the problem continues and haunts me. So I end up with a 200 euro graphics card with insane capabilities that i can't even use (it even managed to crash on my internet explorer ). I put my composants here, I hope that someone will be able to solve my problem.

Composants : Processor : Intel i5-7500 Kaby Lake.

                       Graphic Card : MSI RX 590 OC

                       RAM: Crucial 8x2

                       HDD & SSD: Crucial SSD and 2 Unidentified HDD

                       MotherBoard: MSI B250 Gaming M3

                       Monitors: SAMSUNG S25D340( Not sure about this )and a Packard bell(idk what is his name it's a very old vga one )

                       Power Supply: Aerocool 650V.

   I've already checked if it was overheating, and it's clearly not that. The max i've got on the Cpu and the gpu was: 62C° and 58C°

The games i've tested : Rainbow Six Siege, Battlefield V, Battlefield 1, Scrap Mechanic.

Hope i'll have some help here.


19 Replies
Big Boss

1. what other hardware do you have?
2. what settings you choose in driver?
3. HDMI or DP? What Screens?
4. Error persists with only one screen connected?

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS

1: I think i have said every important composants of my pc, except for the keyboard mouse mic headset and the case i don't see anything else to say about my hardwares. I'm on windows 10.

2: I've installed the drivers normaly, the only thing i've changed was the factory install

3: One is on HDMI and the other one is on DP( i have an adaptor, from DVI to DP ). 1st one is the S24D340 of samsung and the other one is the Maestro 225DXL of Packard Bell

4: I'm going to try this tomorrow, i'll keep you informed.


Quick Update :  I've just tried to play with one screen and it just crashed way faster than before, i've tried to open my pc too to check if it was overheating and it wasn't. It leads to a crash at the start of the game.


mh, thats strange - usually with only one screen it should work fine.

try this:
1. disconnect screen - boot - test
2. boot - disconnect screen - test

"underclock" your GPU - maybe your FatBoys Quality doesnt allow that high factory oc (RMA?) - tetst again

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS

Hi  I've just tried, and both of them result into a crash 

            1.Crashed in approximately 4-5 mins

            2.Crashed in 2-3 mins

 -- Only tested on Rainbow Six Siege for now, idk if i need to test on more games --

(Sorry for answering 2 days later btw )


Did you make surte to verify the game files?

What OS are you running - Windows 10?
Which build?

Are Windows Updates completely up to date?

Are you overclocking the CPU or the RAM?
If so remove the overclock for the moment.

Make sure you reset the GPU to default profile and do not overclock or undervolt the GPU or GPU VRAM.

Start windows cmd with admin privileges.
Run the following.
chkdsk /scan

sfc /scannow

DISM /Online /Cleanup-Image / ScanHealth
and depending on the result of the above:
DISM /Online /Cleanup-Image / RestoreHealth
Those should indicate if your your Windows 10 OS is O.K. or not.

Once you have tried the above please let everyone know the results.

Hey, i've just tried every step, and i got one problem, at the sfc /scannow command :

   - it said that "Protection of windows resources detected corrupted files, but could not repair some of them. For online repairs, [...]

  - At the DISM/Online /Cleaup-Image /ScanHealth command, it simply said "The component store is repairable. The operation was successful."

I didn't do the scnd command DISM/Online /Cleaup-Image /RestoreHealth, because it as i see said that my windows was ok.


You need to run
DISM/Online /Cleaup-Image /RestoreHealth
followed by another sfc /scannow

DISM/Online /Cleaup-Image /ScanHealth
If they do not say everything is O.K> then you will have to repair Windows using other methods.

For the command : DISM /Online /Cleanup-Image /RestoreHealth,

it says :Source files not found.
Use the “Source” option to indicate the location of the files needed to restore the functionality. For more information on the source location specification, see Linkid=243077.

The DISM log file is located at C: Windows Logs DISM dism.log
PS C: ****:****:Documents> DISM/Online/Cleanup-Image/Scanhealth


First thing to do is get an external usb drive and use:
Control Panel\System and Security\Back up and Restore (Windows 7)
to create a full system image backup to the USB drive so you will have a copy of everything.
Once you have created that backup, then you can proceed to attempt to repair your Windows installation. 

Alternatively if you already have a windows 10 backup software that actually works, try using that to create a backup. I have yet to find one.
You could also try disk cloning software to create a backup image of your hard drive.

DISM with /source option rarely works.
If you look at the DISM.log and the CDS.log files they will likely point to missing files that are related to corrupted files from Windows Update Service Packs.
You will have a hard time trying to find the exact Service Packs those corrupted or missing files.
Microsoft do not make it easy.

So I think your best options are: 

1.  Try to repair your Windows install and try to keep all of your files and Apps (only works on Win10 install, not Win7 or Win 8.1 -> Win 10 upgrades).
2.  Create a bootable usb windows 10 install drive. Boot into your existing windows installation. Connect the usb. Run an in pplace install of windows 10 using the startup file on the USB Drive. That should allow you to keep most or all of your files and Apps and Desktop Programs. 
3. Final bad solution. Full Windows 10 reintall and rely on the System Image (Windows 7) Backup to get your data back.



Hey, tomorrow is my last opportunity to send back the card, so i guess i'm going to send it. Thank you guys very much for the help ! I'm going to buy another one but from nvidia this time, i'm really hoping this one will work. Btw do you know how to close this forum page ? 

With all my gratitude, Alexis.


You will still need to repair your Windows installation before installing a new GPU.
Not sure there is any proof at all there is anything wrong with the RX590 in this instance though.


Journeyman III

        I'm having the same problems with 5700 xt. It keeps crashing and black screen. I clean reinstalled the windows and drivers, installing them and  testing them one by one to see which one was causing the problem. All the same. Finally I deactivated all Radaeon features like anti-lag and such ant it seems to work for now for the games but discord and chrome still crashes even if I have disabled hardware acceleration

PC spects:

i9 9900KF,

gpu powercolor 5700 xt,

32gb ram hyperx 2666 mhz,

mobo asus tuf z390-plus gaming (wi-fi), 

 psu corsair 850w

monitor SAMSUNG 27'' LC27JG50QQUXEN


There is no reason for people to call their GPU "Fat" ot "Thicc".

Try the following solution.
Run DDU in safe mode and uninstall AMD Drivers.
Power down the PC.
Remove AMD GPU.
Return it to seller and ask for a refund.
Sell it to someone else if your conscience allows it.

Fit Nvidia GPU.
Boot up the machine.

Install Nvidia GeForce Experience and latest Nvidia Drivers.

Problem solved.


why are you here if you dont want to help people? like saying buy Nvidia is not the best thing - and especially if you watch that they also have problems! (just read in their forums)

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS

Sure there may well be problems with Nvidia GPUs reported on their forums.
I have been running Nvidia GPUs for years.
I only go on their forum once I can remember to report a bug which was fixed within a month.
I am trying to help people on here.
I am never off this forum reporting bugs / problems and trying to help with solutions.
Go figure out what that says about Nvidia versus AMD Drivers and GPUs to me.
I often find that removing AMD GPU and Drivers and replacing with an Nvidia GPU solves the problem for me.
These recent Adrenlin 2020 drivers and GUI/UI are very bad and that is why I gave that advice.


If you cannot return to seller or sell the GPU or you want to stay on AMD GPU then use DDU in safe mode disconnected from the Internet to remove whatever AMD driver you are running. Boot into Windows  mode, still disconnected from the Internet. Try installing Adrenalin 2019 19.12.1 driver. Reboot the PC. Reconnect to the . Try your GPUInternet running Adrenalin 2019 19.12.1.
Official Display Driver Uninstaller DDU Download 

If it works on Adrenalin 2019 19.12.1 then you can consider experiencing the full power of the dark side and try out the new Adrenalin 2020 20.1.4 driver that has just been released: 

Good luck. You never know. It might work.

I'll try it soon and keep you informed about it ! Thanks for the tip !

Journeyman III

I have same problem with my Asus Dual rx 5500xt.

sometimes when i try to open World of Tanks or PUBG Lite my screen goes black for 2 seconds and does same thing after 5 seconds. When my PC loads game screen goes completly black. I can somehow fix that but after restart it does same thing. My current driver is 20.2.1.