Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Wrong Native Resolution

Hi, I have been having the problem for more than a year now. I actually created a ticket to AMD support and when we tried multiple things they told me to file a bug report and wait for a new driver, well, multiple drivers were released and none of them solved the problem. Yet I suspect the problem is the drivers because 2 years ago my correct native resolution was being read.  The significance of the problem is I can't enable FSR or RSR. 

Now for the details of the issue. I have a 4K Bravia Sony TV connected to my PC. The recommended resolution on Windows is 1920*1080. The same for Catalyst drivers showing it as native resolution. Yet even according to the manufacturer website the native resolution is 3840 or something, diffinitly not 1080p

Previously I tried everything based on request from AMD support, updated drivers, clean installs, changed the HDMI cable, updated the TV software and even flashed the card drivers with the latest from the manufacturer. 

I faced this issue in Windows 10/11

I recently even changed the motherboard from X570 to B550 since the previous motherboard got short circuited. So the only constant is this issue. 

My setup 

Asus B550 motherboard, CPU Ryzen 3600X, card Gigabyte 5700XT

Is there a way to force the correct native resolution so I can use FSR/RSR? 

 Tldr: I want to use FSR/RSR, Catalyst won't play nice with my TV and reads wrong reolution. 



3 Replies
Adept II

Why are you using Catalyst? You should be able to get Adrenalin drivers, no?

Uninstall the drivers and ensure you have downloaded them from AMD site above. Hope this helps.


Sorry, that was a mistake, an old timer like me just still stuck with the old name, 

Yes I'm using the latest Adrenaline drivers.


Ah yes I understand though I will never mistake for catalyst as they were terrible drivers lol.

Can I ask what your Sony tv model number is, just to look at it. I know you said it worked before, but have you also tried a reset on the TV. I know Bravia TV's have also their stories..

Are you using the TV as a 2nd screen? If so, please try disconnecting the main monitor from the video card and just let the TV on. Restart and see what Adrenaline reports.

I find it so confusing how they layed out the display settings on Adrenaline, but for some reason display settings is under Gaming>Display. Once you're there you can check what display specs are shown (ensure you do this with just the TV connected).


If the details and specs are recognized correctly, and you don't have set up any custom resolutions (on the right of that screen) you can also test creating one by selecting create new, but ensure the info you add there is correct. All this is assuming your TV doesn't have any settings changed from default or res lowered down.