Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Latest drivers recommends wrong resolution and is missing native resolutions.

This is an R9 390 with a DP to HDMI adapter connected to a Samsung NU8000 TV.  It worked perfectly for a long time but after having formatted and reinstalled drivers it now recommends 4096x2160 as the resolution.  The signal resolution is also 4096x2160 which makes text look TERRIBLE in HDR mode.

1440p is also now completely missing.  4k @ 60Hz is also missing.  I can get the 4k @ 60Hz working with a custom resolution but I absolutely CANNOT get 1440p @ 120hz working.  At first I thought maybe the cable or adapter had gone bad until I rolled back to the drivers on my video card's site (15.something) and voila, all correct resolutions are there, standard 4k is recommended, 1440p @120 is available.  Obviously not using that driver since a lot of modern games won't play on it.

I've worked my way up from old to new all the way to 19.1.1 and it's working and looking at my download history I've gone from new working backwards to old down to 19.10.1 and this driver does not work.  So somewhere between 19.1.1 and 19.10.1 I've lost proper support for this monitor.

Any ideas for a fix so I can run the latest drivers?

0 Replies