Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

some programs not launching after install of Chipset Driver

After installing the latest chipset drivers the system acts highly weird.

Most prominent, Windows-P (key) for projection or monitor settings does nothing, the associated window will not pop up, sometimes after about 10 minutes it appears. While waiting for the appearance, opening programs requiring UAC confirmations will not start, subsequently blocking the system entirely.

Also some programs will not start, regardless Windows-P was pressed or not.

It proves  v e r y  difficult to completely get rid of the chipset drivers and return to the previous version. All works well again now.

MSI A520M PRO, bios 7D14v19, A520 chipset
AMD Ryzen 9 5900X Processor
Nvidia GT1030 grafic
Windows 11 latest version


12 Replies

There are also multiple reports on other forums, that this chipset driver causes Windows Terminal commands like "sfc /scannow" or "DISM /Online /Cleanup-Image /RestoreHealth" got stuck and never ran through or in some cases to be extremely slow in execution.

Even Windows Event Log stopped working.
Others report that a loss of 10 FPS in CPU bound games as well.

For now it seems best Not to use chipset and if installed and encounter any problem: roll back to chipset driver

Best regards from Sweden

Ps. @Matt_AMD regarding this thread, something to look into...
I will stay away from chipset on my mobo: Asus ROG Crosshair VIII Hero X570

Thanks for the feedback. Could you share any links to these forums so we can look into it?

Hi @Matt_AMD 
I can't remember all of them but at least here are some sites.
Please see the comments below the article:

AnandTech forum:

Btw. Regarding installation problem, this post has a special instruction of how to fix it, but I really don't understand why it should be necessary unless something is wrong with the chipset installer itself?
Perhaps it is best to uninstall the old chipset from Program and features, restart the pc and then install the new chipset and restart the pc again.

Best Regards from Sweden

Thanks for the links. We have some users saying the issue regarding SFC /Scannow is resolved after updating Windows via Windows Update. I have just updated my Windows installation and do not see that issue anymore, the scan completed in a minute or two.

I'll keep an eye out for any other issues regarding installation, etc.

I've notice that DISM commands on my build for the last year will not start. 

They just hang at 1% and will not proceed,

All other Command Prompts work.

I've even tried the Power Shell versions of DISM commands and my PC just locks up.

I can always hardboot or ram clear my PC and everything comes up normal even CHKDSK and OS file integrity checks.

I wonder if the various Group Policy Editors I've had to employee have had an affect on DISM commands in windows 10 pro 64.

Fortunately I have other software that does the same thing as DISM commands through my AV.

Though I would like the command prompt versions to work to see if either of the separate software's catch issues that the other may miss. 

Journeyman III

Hi i have problem too with install. Then i someone fix it and install corectli (uninstall, sfc /scannow,delete install extracted files) but AMD powerplan its very unstable on my system, i have stuck problem (3600,Asus B450-i, STOCK frequency), external USB 3.2 M2 ICYBOX unstable too after 10 min they on off not recognize. So i go backroll back to 3.10 version.

Adept II

One more very important problem if this new chipset driver is decreasing perfomance in games which depend on CPU perfomance. In CSGO after update i lost 15-20% of my fps.... I compare one point in game... BEfore instal 280fps, after - 230...


Have you tried adjusting the sensitivity on your Anti Virus software?

If you are running a VPN while online gaming they can reduce your bandwidth and framerates by 30 to 90%.

The game could have a high server players count which will cause lag and FPS drops.

All online games I play start having disconnects FPS drops and game shutdowns straight to windows within a week before server maintenance is announced.



I dont use VPN, windows defender only turned on


I was wary of installing the latest version of AMD CHIPSET package 4.xx.xx due to so many complaints from Users here at AMD Forums.

I decided to see if I also have issues  with this version so I installed it. The Chipset package installed successfully except the Ryzen Power plan which I unchecked from updating.

Rebooted into Windows without issues. After reading this thread I decided to see if DISM works or not. It ran without issue and finished successfully.

I have a Asus TUF GAMING X570 PRO (WiFi) Motherboard with a 3700X processors with latest BIOS version and Windows updates installed.

My computer does have at times some weird behavior where my Firefox will sometimes just close by itself after freezing for a few seconds or some programs seems to have gotten corrupted and I needed to reinstall them again but this has been happening for a while before installing the chipset drivers. The above doesn't happen very often very little in fact.

It could be a Windows Update issue causing all these strange behaviors on my computer.

One thing I noted in Revo Uninstaller I can individually uninstall each of the new AMD Chipset drivers that were installed besides the AMD CHIPSET itself. Which is nice.

I've noticed on my PC a steady increase in web browser issues.

The problem only occurs when web browsing and the site and web browser doesn't matter.

I have Edge Chrome Firefox and Secure Browsers through my AV the latter or less effected.

What happens is I can be on YouTube Newegg Local News Livestream any site and my interment will just cut out.

My modem/router is still working fine. I've tested this by turning on my Xbox and it has no problem connecting while my PC generally takes a hardboot or ram clear to reestablish connection.

What I have noticed is each time this happens my VPN service will search for other locations in quick succession until it finds a stable connection.

Used to be a rare event happening about once every 3 to 4 months. Now it happens weekly sometimes up to 10 times a day. I've had my ISP change my router/modem twice to a different model both times. Just last week they ran entirely new coax (Rg6) and phone line (CAT 3 standard) yet the problem continues.

I live in a small community of about 500 people several with different ISPs and the whole community is having similar issues. Even the ISP I use covers a large part of the northern end of my state their techs have said this is an issue across their whole coverage area and has only gotten worse. This last part is in their best interest to resolve because they provide internet service for a lot of business's in the Dallas Fort Worth area talking about 1.4 million people.  

Journeyman III

... maybe it is a problem for chipset A520 (with Ryzen 9 5900X ) only?