Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Radeon VII + AMD Radeon 2020 (19.12.x) causing PC to crash

Hi guys,

Since upgrading to the new AMD Radeon 2020 (19.12.3) driver, my PC is very unstable. In most games and benchmarks my screen goes black (actually in Battlefield 5 I've had most success in replicating it). After about 2-3 seconds the sound stops working and the PC either shuts down completely,hangs, or reboots itself. Using an older driver (the 2019 version) will solve the issue.

I don't think this is how it's supposed to work.


Gigabyte Aorus Master X570 motherboard

AMD Ryzen 3950x CPU

32gb (2x16gb) G.Skill F4-3600C16D-32GTZN (XMP enabled)

AMD Radeon VII (stock)

So far I've tried everything. Full re-install, DDU, setting GEN3 in my BIOS. Re-installing chipset drivers. Undervolting... you name it.

Please look into this.

99 Replies
Adept II

My Radeon VII is stable with the 19.11.3, too. Every version with 20up is unstable and reboots when i need the power (Gaming or COMPUTE) . 


R7-3700X&AGESA1.0.0.4B+32GB RAM+750W beQuiet DarkPro PSU+VII with standard frequencies/voltages or UV@990mV...


I sended error reports to AMD Support because of the reproducible application errors of Radeonsoftware.exe and reboots(black screen) showing in the Windows event viewer.


AND MAYBE YOU can see it on your system: with the 20up versions there is no Compute 2 section in the Taskmanager at the GPU section anymore. Just Compute 0,1,3. 
This "could maybe" be one of the reasons the VII/the whole system crashes and reboots when there is full load on Compute units. Users with 5700XT and Vega 56/64 don´t have Compute 2 too (asked&found in the german Computerbase-Forum).


With the "old" 19.11.3 the Compute 2 section is active&showing again and i can game and compute with full power without reboots and errors. (BUT i can´t use AMD LINK because of the "new" App-Design/requirements ).

Not applicable

Comment edited to preserve sanity.

We have tested the Radeon VII on the 20.x.x drivers and they all randomly crash out the unit with a black screen, no BSOD log, the unit resets and after maybe 5 crashes the display driver was corrupted.

We need to disable the powerplay features on the Radeon VII, this is downclocking the core/memory and crashing the GPU.

We even modded the driver for 99% power, still downclocks.

Example Battlefield ingame spikes down to 130mhz, results in major movement stuttering or BSOD.

I have never seen such trash from this company.

We need the 'Power Efficiency' feature that was removed from the AMD driver on the VII GPU. 

Adept I

Against my better judgment, I went ahead and installed this latest update. I was okay with The Division 2 but crashed out on Ghost Recon breakpoint.  Went to a black screen and I had to reboot.  It happened while I was in an area that was a bit more graphically intensive.  Did it crash because the card is starved for power?  I did not under volt nor did I select auto under volt in the 2020 menu.  

Rebooted and went into Adrenaline 2020 and then went to tuning > power tuning > set to on.  Under power limit %, I cranked it all the way up.  I did not adjust anything else but you're welcome to try if this doesn't work for you.  

Loaded up Breakpoint and repeated the same steps that caused the crash. No issues.  I need to test more but if this holds, it could mean this software and drivers are messing up the power settings and not letting it get the power it needs to do what it does.  Too soon to tell but that's what it's looking like.  

Unbelievably bad job if so. I continue to be amazed at how sloppy AMD has been with this rollout.  Did they lay off their QA department? If so, we should bill them.  

Breakpoint wouldn't be a good testbed considering the issues the game devs are working on (patch due later this month ?). 

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

Good point. It is a problematic game even without the current driver issues.  I’ll try some other games and put it through some stress tests via 3D Mark. 

Then, of course, there’s the most basic test which the other drivers failed at. The simple act of web browsing. I don’t know about anyone else but simply going to Youtube or even doing some online banking didn’t agree with the next gen drivers. I’ll have some time later today to try most of this.  


Did some stress tests via 3DMark.  Both Time Spy and Firestrike extreme.  Ran them multiple times.  Everything held together. Passing score of 99% each time.  Set power limit back to the default value (50%) and within moments, Time Spy froze.  I didn't get the black screen but I had to reboot.  I couldn't get back to the desktop.  On reboot, set power limit back to 100% and it held together.  

I'm sure it's not just this setting alone but part of a series of things going wrong.  I still have to test more.  


The Power Limit in Wattman and 'Performance' setting on your computer are two of the most important and less understood settings for a gamer Setting the computer power plan to 'Performance'  (instead of the default Balanced) benefits in many areas, the most relevant is it unparks all CPU cores.

The default setting for the Power Limit in Wattman is a power saving feature. It will throttle the card when it draws too much gaming.  You must set it to the maximum + value..slider all the way to the right, this disables the throttle and lets the card perform. Don't forget to click apply at the top of the page.

Here is a old post but still relevant:

AMD graphics performance 

Adept I

I've been having the exact same issues as you guys, black screen then system crashing usually while gaming, but does it while watching videos on slimjet browser as well.

Tried everything I can think of, reinstalled windows, different PSU, etc. No luck.

I used the AMD removal tool yesterday and reinstalled the most recent driver and after testing some of the games it crashed with the most it seemed fine up until about 8.30PM today where after maybe about an hour on GTAV bam, system crash.

Currently rolling back drivers to see which is the most stable for me.

I really hope AMD are looking at this, as it has just been frustrating to no end.

Update: Installed 20.1.3 a couple of nights ago. So far no system crashes. We might be onto a winner here.

Another update: OK spoke too soon. Just crashed after about an hour of GTA V. Crashed right after alt-tabbing out to the browser.

Not applicable

Its the core MHz fluctuating out of control, we have spikes of 2662mhz, its a joke, this is why the GPU cuts off with the black screen of death.

AMD removed the 'Power Efficiency' feature from the VII, it works with the FuryX, but not with the VII.

Adept II

I'll save you guys the hassle of trying 20.1.3... same result. Black screen + reboot after not even 15 minutes of Battlefield 5. This is getting out of hand. Us Radeon VII owners are not even in the Known Problems list!!

Journeyman III

I have a Radeon VII as well that I got and put in a PC I built weeks ago and it has the same issue, only it doesn't matter what game, I could be playing Two Point Hospital which isn't even that high end of a game and it will black screen and reboot. Even something like playing Team Fortress 2 will have this issue, which is just pathetic when a so called "high end" GPU crashes on what is essentially a game from 2007. Did I make a mistake going with AMD for a GPU? I just wanted a totally AMD machine.

Adept I

Edit:  I contacted Amazon and they said send it back!  Not a problem.  Goodbye AMD.  And best of luck to you all.

I've got this idea churning in my head about why AMD tech support is so very eager to tell you it's a defective card and to return it.  I'm thinking that they know they aren't going to pay any attention to the drivers for these cards at all, and so the issues you are seeing essentially become hardware defects... By telling you it's a defect they can wash their hands of it.  I'm considering contacting Amazon and forwarding the product defect message I received from AMD, and see if that results in me getting my money back.


How did it turn out in the end? Amazon refunded your order?


Yes they refunded it.  I linked to this forum when I submitted the claim, and they called me. They processed it as a defective product.  I installed a different card in the computer and i have had zero problems.  Never again...  In another computer i'm running an RTX 2080.  When i first received the card, when it had only been on the market for 2 months, there was a very common issue of those cards flickering at the desktop.  They resolved that issue with a driver update after about 3 months.  

The problems with the Radeon VII are far more severe, are continuing for over a year, and have no real acknowledgement through driver notes that the product has a problem.  I would RMA that @#$%@ SO FAST


Well you waited like 2 months. Its like a TV. If you see a tiny dot on the screen. Just accept someone through your Monitor. the same thing with your graphics card. When people ship your stuff. It looks like nothing happened. But it may have fallen 40 feet from a plane due to it not being tied down. Yeah i see where you are coming from on this. I would just immediately send it back. Because these guys handling your stuff.... they have issues.

Adept II

Ok its only been a day but have had no black screen of death since doing a clean uninstall with DDU utility and installing 20.1.3 drivers have to test further today


Radeon VII 2020.1.3

Windows 10 pro

x570 Crosshair VIII Hero

AMD 3900x

32 Gigs Gskill Royal 4000/...runing at 3600 16.16.16,38

world of tanks makes the GPU work so going to run that  all day and night see what happens



Ok all day running 100% GPU load and 112 C junction temp anyone want some bacon and eggs lol.

see if it holds out for another 8 hours or so


ok after a full day of running World of Tanks and making the inside of my case an easybake oven lol Driver 20.1.3 seems to have fixed the black screens and reboots for me

Adept I

Yeah 20.1.3 works really great! 5 minutes after installation and running a distributed computing project called einstein @home I got a complete freeze-

Problemereignisame: APPCRASH
Anwendungsname: Radeonsoftware.exe
Anwendungszeitstempel: 5e221339
Fehlermodulname: Radeonsoftware.exe
Fehlermodulzeitstempel: 5e221339
Ausnahmecode: c0000005
Ausnahmeoffset: 0000000000405407
Betriebsystemversion: 10.0.18363.
Gebietsschema-ID: 3079
Zusatzinformation 1: 0f1e
Zusatzinformation 2: 0f1e8efbe4eda39817605f485fdb728a
Zusatzinformation 3: e8be
Zusatzinformation 4: e8be9d812a8f09acb40b4093b1c3d836

Weitere Informationen über das Problem
Bucket-ID: 043065ce9651e416e90a6a1938a7afb7 (1804371257272545207)

But at least it was no black screen... I also noticed less power draw and lower gpu clock speeds with 20.1.3. If that's their fix - well done...

I'm back to the 19.7.5 drivers which are the last ones that work for me...

ASUS ROG Crosshair VIII Hero, Ryzen 9 5950X, 64GB G.Skill Trident Z Neo 3600Mhz CL16, Radeon VII

Too bad. 20.1.3 is still buggy. Showing hardware failure and freezes and crashes when i test with AIDA GPU stability test or use  BOINC GPU Crunching.
So i used the error reporting form from AMD again...

AND Compute 2 @ Taskmanager @ GPU is still missing with 20.1.3.
So Compute 1 is showing the load on the GPU. 
With the reinstalled stable 19.11.3 it´s fine (no crashes or freezes/no event viewer logs related too AMD GPU/radeonsoftware.exe). The Compute 2 reappears and is showing the GPU workload instead of Compute 1.

Same problem here with my Vega 64 when transcoding video using openCL and AMF encoder. After a few minutes of high load on the GPU, the system freezes and can only be resolved by restarting. Compute 2 in taskmgr is also missing in latest 2020 driver. The last stable driver for me is 2019 19.12.1.


Do you have HBCC enabled? Regards.

Adept I

I have the same problem. And I just now realized that there are just a bunch of problems with AMD drivers. Firstly, no user settings are saved in any driver version, namely they automatically fly off after each reboot. Frequent crashes, especially if you want to turn off some parameter during the game, or see what’s done with the temperature certificates. In general, all the time on needles, but I would like to enjoy the games. And in the last driver 20.1.3 in general, crashes and reboots had to be rolled back to the old days, although there were at least fewer problems.

Adept II

Sigh, I gave 20.1.4 a try. I got a complete freeze + reboot after ~20 minutes of playing Battlefield V...What is going on AMD. When is this getting solved?

Meanwhile I'm rolling back to 19.12.1 (yet again).

Resorted back to 19.12.2 drivers and 2 days no Black screen or crashes

still testing......gaming elite dangerous Rift s VR cool stuff even with streaming is stays with it although world of tanks is what AI deen to run to tax the GPU more

Adept II

I'll save you guys trouble yet again; Just installed 20.2.1, booted up Battlefield V and literally got a black screen + reboot not even after 4 minutes. I'm just as a loss at what to do, file a warranty claim?

Meanwhile, yet again.... for the 10th time, reverting back to 19.12.1.

I'm losing faith.

Not applicable

Its because of the missing Power Efficiency option for the VII, Im still waiting for a reply from AMD, I suggest you contact AMD directly and request the feature be put back, otherwise the VII is a dud. 


Any word from AMD yet?

Journeyman III

Hallo Guys,

Here´s just a new member for the black screen club!

I took my whole PC apart, switched several components and was almost freaking out while trying to get my Radeon VII stable!

Then i find the guide for manually rolling back to old drivers here, now my system is finally working stable ( with 19.11.2).

Thank you for that!

Well, undervolting seems not to work properly with this driver version and i had to disable hardware acceleration for some applications to avoid massive image errors, but at least it´s stable now.

Adept I

Another member as well! Glad to join the club! I figure at this point all Radeon VII owners are, some just don't know it and there's only so many of us.

While I'm more stable on older drivers, does anyone else have instability on all drivers? 19.11 to 19.5 are the most stable, but I still get black screens on these drivers. And I wonder, for those who say some driver is stable for them, have they just not sunk enough time into gaming on it to show its actually unstable? I'm sure its all related to awful power management that's non-existent in all drivers.

Is there a way to force the power management issues away?


I resorted back to 19.12.2 and black screen only happened once when I switched my EDH game to full screen black screen happened when I alt tab'ed out lol but other than that it's been stable


All versions are unstable for me. Unfortunately, "only happened once" means its still happening for your setup as well.


For me, 19:11:2 is the last stable driver but according to some comments i have read, some people even need to go back to 19.11.1.

I used my PC for about 60 hours since i rolled back.

I´ve played various games, watched some movies and did a lot video edditing with Davinci Resolve.

I also did some benchmarks and stresstest with 3Dmark, furmark, memtest, Prime95 and cinebench.

You see, i did my best to provoke a crash but nothing happens.

But the buggy hardware acceleration and useless undervolting/overclocking is annoying me, so i hope they´ll bring a new stable driver soon!

Adept I

Adrenalin 20.1.4 worked for me fine. (Ryzen 7 2700x & ASRock Radeon VII)


Do you see/have a Compute 2 section @ the Windows Taskmanager|GPU or just Compute 0,1,3?

Do you use the raw compute power of the VII für BOINC/Milkyway/Einstein etc. or gaming?
Do you undervolt the VII?

Are there logs for application error of radeonsettings.exe in the Windows event log?

Adept I

I think I’m in the clear with the latest update. Instead of manually ramping up power to as high as it can go, I switched things back to automatic and gave it a go. 

No crash after many hours of gaming. 

I took it one step further and switched from the standard profile to the gaming one. Something that was a guaranteed crash on my system. 

No issues at all and a slightly perceptible performance boost but nothing remarkable if you don’t want to use it. 

So I’m relieved for now but wonder how long it will be before AMD finds a way to mess this up. Fingers crossed they don’t. 

Adept II

Well I think we're in the clear with the drivers that launched today. So far I haven't gotten a reboot or black screen. You should should try it out as well.

Adept II

1. Tried the new 20.2.2 driver too, but it still crashes the system like the other 20´s when i use the Compute Power.
This time with memory dumping error... so i used a tool to read the Dump-File.

ffffb307`5154fa08 fffff800`564d0aaa : 00000000`00000116 ffffe60c`86b68010 fffff800`59b70818 ffffffff`c0000001 : nt!KeBugCheckEx
ffffb307`5154fa10 fffff800`5647fe9b : fffff800`59b70818 ffffe60c`7c8d1000 ffffe60c`7c8d10d8 00000000`00000000 : dxgkrnl!TdrBugcheckOnTimeout+0xfe
ffffb307`5154fa50 fffff800`56480986 : ffffe60c`7c8d0100 00000000`00000100 ffffe60c`7c8d1000 ffffe60c`7c8d19e0 : dxgkrnl!DXGADAPTER::PrepareToReset+0x1a3
ffffb307`5154faa0 fffff800`564d01e5 : 00000000`00000100 00000000`00000000 00000000`00000000 ffffe60c`87710040 : dxgkrnl!DXGADAPTER::Reset+0x276
ffffb307`5154fb10 fffff800`564d0347 : 00000000`00000100 ffffe60c`83eb8618 ffffe60c`72e79cc0 fffff800`5e776d80 : dxgkrnl!TdrResetFromTimeout+0x15
ffffb307`5154fb40 fffff800`4a0f43c5 : ffffe60c`87710040 fffff800`564d0320 ffffe60c`72e79cc0 ffffe60c`72e79cc0 : dxgkrnl!TdrResetFromTimeoutWorkItem+0x27
ffffb307`5154fb70 fffff800`4a06bce5 : ffffe60c`87710040 00000000`00000080 ffffe60c`72e93040 3f40709a`60000000 : nt!ExpWorkerThread+0x105
ffffb307`5154fc10 fffff800`4a1c99ca : ffffba80`66840180 ffffe60c`87710040 fffff800`4a06bc90 3ea0d6e7`20000000 : nt!PspSystemThreadStartup+0x55
ffffb307`5154fc60 00000000`00000000 : ffffb307`51550000 ffffb307`5154a000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x2a

SYMBOL_NAME: atikmpag+10818

MODULE_NAME: atikmpag

IMAGE_NAME: atikmpag.sys

IMAGE_VERSION: 26.20.15019.15019

STACK_COMMAND: .thread ; .cxr ; kb

FAILURE_BUCKET_ID: 0x116_IMAGE_atikmpag.sys

OS_VERSION: 10.0.18362.1

BUILDLAB_STR: 19h1_release


OSNAME: Windows 10

FAILURE_ID_HASH: {e300aa8c-6915-3f37-7957-d2e4fc30a6fd}


2. The "Compute 2" section isn´t showing in Taskmanager for the GPU, just 0 and 1 and 3. 

Then deinstalled the Adrenalin 20.2.2 (DDU safe mode etc.) and installed the "old" 19.11.3 = no problems with crashing, but no AMD LINK anymore. The Compute 2 section in Taskmanager  is back again.

I like the VII because it was and is still the performance flagship (it is most equal and often faster than the 5700XT in many games in UWQHD 3440x1440 with average fps and frametimes and much more powerfull in Compute tasks).
Too bad that i can´t use this great software feature AMD Link.

I'm seeing the same issue on 20.3.1, but weirdly it only seems to happen if I'm on a video conference using Teams. I can run Folding@Home and play games just fine for hours, but get on a call for 10 minutes and it'll black screen and reboot.

A WinDbg !analyze gives this:

******************************************************************************* *                                                                             * *                        Bugcheck Analysis                                    * *                                                                             * *******************************************************************************  VIDEO_TDR_FAILURE (116) Attempt to reset the display driver and recover from timeout failed. Arguments: Arg1: ffffc60319573010, Optional pointer to internal TDR recovery context (TDR_RECOVERY_CONTEXT). Arg2: fffff8065e940818, The pointer into responsible device driver module (e.g. owner tag). Arg3: ffffffffc0000001, Optional error code (NTSTATUS) of the last failed operation. Arg4: 0000000000000003, Optional internal context dependent data.  Debugging Details: ------------------   KEY_VALUES_STRING: 1      Key  : Analysis.CPU.Sec     Value: 4      Key  : Analysis.DebugAnalysisProvider.CPP     Value: Create: 8007007e on MYPC      Key  : Analysis.DebugData     Value: CreateObject      Key  : Analysis.DebugModel     Value: CreateObject      Key  : Analysis.Elapsed.Sec     Value: 21      Key  : Analysis.Memory.CommitPeak.Mb     Value: 64      Key  : Analysis.System     Value: CreateObject   ADDITIONAL_XML: 1  BUGCHECK_CODE:  116  BUGCHECK_P1: ffffc60319573010  BUGCHECK_P2: fffff8065e940818  BUGCHECK_P3: ffffffffc0000001  BUGCHECK_P4: 3  BLACKBOXBSD: 1 (!blackboxbsd)   BLACKBOXNTFS: 1 (!blackboxntfs)   BLACKBOXPNP: 1 (!blackboxpnp)   BLACKBOXWINLOGON: 1  PROCESS_NAME:  System  STACK_TEXT:   ffffd803`18bbfa08 fffff806`5f12fcca : 00000000`00000116 ffffc603`19573010 fffff806`5e940818 ffffffff`c0000001 : nt!KeBugCheckEx ffffd803`18bbfa10 fffff806`5f0df1ab : fffff806`5e940818 ffffc603`15bec000 ffffc603`15bec0d8 00000000`00000000 : dxgkrnl!TdrBugcheckOnTimeout+0xfe ffffd803`18bbfa50 fffff806`5f0dfc96 : ffffc603`15be0100 00000000`00000200 ffffc603`15bec000 ffffc603`15bec9e0 : dxgkrnl!DXGADAPTER::PrepareToReset+0x1a3 ffffd803`18bbfaa0 fffff806`5f12f405 : fffff806`00000100 ffffc603`1d304080 ffffc603`1d304080 ffffc603`1b7e0040 : dxgkrnl!DXGADAPTER::Reset+0x276 ffffd803`18bbfb10 fffff806`5f12f567 : 00000000`00000200 fffff806`4f838be0 ffffc603`0be93c20 fffff806`4f4850e0 : dxgkrnl!TdrResetFromTimeout+0x15 ffffd803`18bbfb40 fffff806`4f4f43b5 : ffffc603`1b7e0040 fffff806`5f12f540 ffffc603`0be93c20 fffff806`5220f1b0 : dxgkrnl!TdrResetFromTimeoutWorkItem+0x27 ffffd803`18bbfb70 fffff806`4f46bcd5 : ffffc603`1b7e0040 00000000`00000080 ffffc603`0bea4300 00000000`00000080 : nt!ExpWorkerThread+0x105 ffffd803`18bbfc10 fffff806`4f5c9968 : ffffda81`b3d19180 ffffc603`1b7e0040 fffff806`4f46bc80 00000000`00000000 : nt!PspSystemThreadStartup+0x55 ffffd803`18bbfc60 00000000`00000000 : ffffd803`18bc0000 ffffd803`18bba000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x28   SYMBOL_NAME:  atikmpag+10818  MODULE_NAME: atikmpag IMAGE_NAME:  atikmpag.sys  IMAGE_VERSION:  26.20.15029.15007  STACK_COMMAND:  .thread ; .cxr ; kb  FAILURE_BUCKET_ID:  0x116_IMAGE_atikmpag.sys  OS_VERSION:  10.0.18362.1  BUILDLAB_STR:  19h1_release  OSPLATFORM_TYPE:  x64  OSNAME:  Windows 10  FAILURE_ID_HASH:  {e300aa8c-6915-3f37-7957-d2e4fc30a6fd}  Followup:     MachineOwner

Basically the driver crashed and Windows was unable to reset it within the timeout so it reset the machine.


You can change the TDR setting: