cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

alexalex
Journeyman III

Radeon 7800 Series - Blue/Black/Red Screen Crimson 15.12

I was not able to play on my video card anymore due to the fact that i got blue/black/green screen every 1-2 mins. I decided to switch to integrate card and after 1 month i wanted to see if the video card still has the issues. But now i can not install anydrives because it says that  "there is no amd hardware installed"

Message was edited by: Matt B


We have updated the title of this discussion with relevant details to better describe your issue.

0 Likes
28 Replies

Please furnish the required information as per AMD Forum: INFORMATION REQUIRED WHEN POSTING A QUESTION .

If your PC is a Laptop - post the EXACT MAKE & MODEL of the laptop.

1. enable all GPUs in DeviceManager
2. uninstall current driver with DDU (in Safe-Mode)
3. after reboot & cleaning & reboot - install driver provided by your laptop manufactorhttps://support.amd.com/en-us/kb-articles/Pages/AMD-Radeon-Software-Crimson-Edition-16.2.1-for-Non-G...

if its working fine

have in mind: it looks like you try to install a not fitting driver for your Laptop - maybe it has a "Non GCN" GPU/APU - so the last try is that you can use: AMD Radeon Software Crimson Edition 16.2.1 Beta for Non GCN Products Release Notes
this should be the last working driver for your Laptop (but i havent tested it myself (will maybe do so - maybe not)) - and there is NO NEWER working driver for your Laptop

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
0 Likes

Where do you see the poster has Legacy graphics? Why should he install legacy drivers?

0 Likes

"I decided to switch to integrate card and after 1 month i wanted to see if the video card still has the issues." - Desktop-APU or Laptop

btw the driver i posted isnt the legacy - it is the only crimson driver that supports old APU iGPUs

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
0 Likes

What?

Crimson driver...was he asking for a Crimson driver? What 'old' APU? Where do you see that? Am I missing something? What OS is he using? Is it a laptop or a desktop?

0 Likes

Some of your comments in a couple of threads have made me LoL.

0 Likes
kingfish
Volunteer Moderator

Please furnish the required information > INFORMATION REQUIRED WHEN POSTING A QUESTION

 

INFORMATION REQUIRED WHEN POSTING A QUESTION

   ray_m

  

 

Providing the information below will get you a faster response from the community.

Describe your system:

  • AMD Graphics Card
    • Make and model; e.g. AMD R9 290X
  • Desktop or Laptop System
    • If a laptop, make and model of the Laptop
  • Operating System
    • E.g. Windows 10 64bit
  • Driver version installed
    • E.g. Radeon Software Crimson Edition 15.12
  • Display Devices
    • Make and model, connection/adapter in use, resolution and refresh rate; e.g. Samsung UE32850R 3840x2160 @60Hz Active DP to HDMI adapter
    • One line for each display device connected
  • Motherboard + Bios Revision
    • Make and model; e.g. Asus P8P67 Deluxe Bios Version 6643
  • CPU/APU
    • Make and model number; e.g. FX 9590
  • Power Supply Unit  Make, Model & Wattage
    • E.g. Thermaltake TR2 700W Gold
benman2785
Big Boss

1. he said "I decided to switch to integrate card and after 1 month i wanted to see if the video card still has the issues." there for he uses an APU - and most likely it will be a Laptop
2. due to his problem i think he installed a driver younger than 16.2.1 on a NON-GCN APU iGPU
3. that special 16.2.1 Driver i provided is the latest APU driver for Non-GCN APU iGPUs
4. it is a Crimson driver beta
5. there is NO ReLive (or no other Crimson) driver for non-gcn gpus

but he should provide more info - so i dont need to specultate over one sentence

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
0 Likes

I saw that too, but I also know that many Motherboards of Desktops have integrated Video not using a APU rather a CPU. The OPS was IMO too vague to suggest anything until he posted more information on his computer.

hehe but then the driver wont show feature to enable dual-graphics...

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
0 Likes
alexalex
Journeyman III

Hello there. So ty all for replying. I didnt post any inf because i didn t know that to post:...so:

  • AMD Graphics Card
    • AMD radeon sapphire 7800
  • Desktop or Laptop System
    • DESKTOP
  • Operating System
    • Windows 10 64bit
  • Driver version installed
    • E.g. Radeon Software Crimson Edition 15.12   untill 3 weeks ago it was the latest driver
  • Display Devices
    • couldnt say exactly an ultrawide lg monitor
    • integrate gpu does not support hdmi (it does not work) so now im using an old acer monitor
    • One line for each display device connected
  • Motherboard + Bios Revision
    • asus...i dont rly know in msinfo it says "not available"
  • CPU/APU
    • i7 3770K 3.5ghz
  • Power Supply Unit  Make, Model & Wattage
    • gigabyte 550-570

the ideea is: suddenly i got random display freezez, blue / black / red screens and then shut down..after that the dispaly would inly work until the windows icon appears then the desktop would go black with the computer still "alive"...as far as i could remember the pc would start and work because i could hear the windows sound but the image would still be black.

3 days ago i decided to try the gpu again but when ever i would try to install  the driver it would say 1)something with legacy and i need a special driver and i found one 2)you have no hardware to match the driver or somehting like that..

the ideea is that the pc does not recognize the gpu hardware anymore and i would like to ask why.. maby the video card is fried..or idk..

Thanks for halping

0 Likes
kingfish
Volunteer Moderator

This is how you select the correct driver > Clean Install AMD Graphics Drivers

You install the full version...not the "minimal setup" >> Desktop

Follow the step by step guide > Clean Install AMD Graphics Drivers

0 Likes

ALready did this. Itwont install because it sais something like” there is no hardware installed for this driver”

0 Likes

"i got random display freezez, blue / black / red screens and then shut down" - it looks like a hardware problem. If possible, test your graphic card in another PC.

0 Likes

i dont rly have where to test it, i went to a hardware repare thingy  and they said that i should run  some game on the integrate videocard and see if the pc works..and it works. So..i guess that the amd gpu is the problem but can it be like burnet and not be recognized by the pc anymore?

0 Likes

Here is a Free program that will give you a lot of information about your computer including Make & Models and so forth. It is called SPECCY.

It is nice and very useful to have in case in the future you need to find out information about your hardware on your computer.

benman2785
Big Boss

you need AMD GPU driver & Intel GPU driver

AMD driver CANT show you to enable iGPU

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
0 Likes

run Furmark + Prime to test your system

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
0 Likes

how long shoud i let the tests run? would furmark run if the pc does not detect the gpu?

0 Likes
alexalex
Journeyman III

I found something maby it matters:

there are 2 cables with 6 pins that goes from powersuply to videocard and as far as i can tell both work ...but only 1 slot from the video card works

0 Likes
alexalex
Journeyman III

yo beautiful people..

So i messed around witht he video card : pushed it harder into the slot, push the powersuply cables etc etc and i think it worked.beacause the dispay would go black after the windows logo so..i didnt load the inegrate video card but the amd one.

Am here with another problem then... why would the display work untill the windows logo pop up then go full black? can it be some idk driver isssue of anithing else or is just the video card that is fried

0 Likes
benman2785
Big Boss

pls boot in Safe-Mode

if that works - so if it boots into safe-mode: it will be a driver error then

uninstall all GPU Drivers

install latest AMD and Intel GPU drivers - test again

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
0 Likes

I booted in safe mode and the display wont shut down but only

for couple of mins, then it shuts down

0 Likes
kingfish
Volunteer Moderator

The issue looks to be beyond your ability to remedy. I would suggest you take your computer to a professional and pay them to get everything back to normal.

0 Likes

"proffesionals" totally bs...i went to 2 profesionals and did shiet...they couldnt tell me what the heck is wrong with the pc..i guesss the problem is with the video card and ill have to get another one..

0 Likes
benman2785
Big Boss

if you are in safe-mode and it boots into windows and then, after some minutes it crashes then you most likely have faulty hardware

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
0 Likes

that is exactly what happened

0 Likes