cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

PiersJH
Adept I

Odd Chipset Install behaviour - 'device not started' in Device Manager (I2C, PCI, GPIO, etc.)

Hello,

I would appreciate if an AMD employee could offer their opinion on this odd situation.

Background

My system specification is in signature. It's a new system (a few months old) and I started with a clean installation of Windows 11. I then installed the latest Windows 11 AMD Chipset Drivers from Asus and ran the simple installer. The log at the end showed 'Success' for each driver and I thought nothing more of it.

The Problem

However, when looking through Device Manager, nothing stood out but I wanted to see more information about the PSP Device. I open its properties and it stated 'This device is working properly', but under the Events tab (still in the item's properties), the drivers that the AMD installer claimed were successfully installed were actually not. The Events tab show 'Device configured' and 'Device not started'. 

Behaviour Noticed

Before I used the fix mentioned below, software using the I2C Super I/O (such as HWiNFO) would report odd voltages that seemed out of specification. One making sure the driver is installed and that 'Device started' is the latest log entry under the device's properties, that same software would then report the expected voltages and clocks.

Affected Drivers

This happened to the drivers for the PSP device, I2C controller, GPIO (2+3), and one PCI - all AMD devices. This happened with each chipset revision (I believe it's been three since Windows 11 was released). Example screenshots below.

 

amd-forum-img1.pngamd-forum-img2.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A (not idea) Solution

The only way to rectify the issue appears to be to uninstall the device (within Device Manager) and delete the drivers, if given the option, and then to search for new hardware. Some items will be automatically installed and will then work. Some items will need the driver. To install that, it's a normal manual driver install (i.e. for the unrecognised I2C device that's produced after the preceding steps, I would go to the device's properties -> update driver -> navigate to the path AMD's installer extracts files to (C:\AMD\Chipset_Software\Packages\IODriver) and select the directory named "I2C". This would then install the driver correctly and under the Events tab within the device's properties, the log would now show 'Device configured' followed by 'Device started'

Updating a Driver

To update a driver, the AMD Chipset Driver installer doesn't appear to work so it's once more a manual process, but slightly different. Using the I2C Controller driver as an example, the installed version was from 2019. I wanted to update that to the latest version. Simply selected 'Update Driver' and navigating to the path doesn't work - doing that results in Events showing 'Device configured' followed by 'Device not started'. Instead, I must manually uninstall the device, delete the driver if given the option, and then Windows will generally install the correct driver.

Conclusion

Despite many AMD drivers showing 'Device not started', the PC generally worked but with instability (I run the PC at stock with only XMP enabled and tested for 48 hours in Memtest and TestMem5) and oddities showing in Event Viewer (uncommon events that shouldn't be showing with a three-month-old PC). Since manually fixing the issue, the PC feels much more responsive, voltages seem much more in line with what I've seen reported, etc. For example, having the I2C driver installed and marked as 'Device started' appears to have stopped VCCDR_CPU (SVI2 TFN) boosting to 1.55000V. Now it's offering the same performance, but will go no higher than 1.50000V.

 

 

R9 5900X • Corsair H150i Pro XT (360mm) • Asus ROG B550-E • 32GB Corsair Vengeance 3600 CL18 • EVGA RTX 3080 Hybrid (240mm) • Corsair RM850X • WD Blue 1TB M.2 NVMe SSD • 2 * WD Blue 1TB SATA SSD • 2 * Toshiba N300 8TB
0 Likes