cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Breaker_
Journeyman III

Multiple StoreMI Issues

Greetings!  First, thanks in advance for any and all assistance.  This may be a bit long, but I want to be thorough:

I currently have StoreMI 2.0.0.0068-BETA installed.  I was hoping to upgrade to the latest version (2.0.0.0130), but have not been able to.  Information on my system and the problem is as follows:

  • My system runs a Ryzen 9 3950X on the X570 chipset.
  • It has four physical storage devices, comprising three "lettered" drives.
    • 1TB NVMe ( C: ) as the boot drive.  Also contains software such as MS Office.
    • 1TB NVMe ( G: ) as storage for most frequently accessed games.
    • 240GB & 4TB ( E: ) StoreMI virtual drive for less frequently access games.
  • The 240GB SATA SSD and 4TB SATA HDD were combined via StoreMI 2.0.0.0068-BETA.  Now, neither drive will show up in the program.  The "Source Devices" section shows "No Source Devices Found".  Similarly, the "Cache Devices" section shows "No Cache Devices Found".
  • I cannot uninstall StoreMI, as it states "StoreMI Installer detects presence of StoreMI Device. Please separate StoreMI Device from application before uninstallation."  I cannot complete this because of the the above point, where no devices are found.
  • The drive I created ( E: ) when I first ran StoreMI (the BETA version listed above) and initially combined them still works.  I can still play games from it.  I can navigate through the folders contained therein.
  • Using Device Manager to view the "IDE ATA/ATAPI controllers", both the 240Gb and 4Tb drives are listed in the "Children" property under a generic "Standard SATA AHCI Controller".
    • There are no devices using any AMD storage drivers listed anywhere in Device Manager.
  • Both drives show up under the "Disk drives" section of the Device Manager, and both are in good working order according CrystalDiskInfo.  Zero errors reported from both drives.
  • If I upgrade to 2.0.0.0130 via its installer, my system will not boot due to a BSOD that shows that the boot device is inaccessible.  At this point I have to restore the system to an earlier point in order to get it to boot again.

Has anyone else run into this issue, and been able to rectify it without reinstalling Windows and starting from scratch?  Again, thanks for any and all assistance.

0 Likes
1 Reply
RyZEN1
Staff
Staff

Re: Multiple StoreMI Issues

If you are seeing "Standard SATA AHCI Controller" then that could be the root cause of the problem as to why the StoreMI doesn't list any drives under it.

StoreMI has its own set of driver which gets installed on "Standard SATA AHCI Controller", there by able to control those drives and show it accordingly in the UI for the user to make the necessary selection and use it.

Looks like, in between the StoreMI drivers got unloaded due to some reason (may be due to system restore???) because of which StoreMI drivers aren't active on the system anymore.

I would suggest you to follow the below:

  • Format the SSD which was used in creating StoreMI so that any traces of StoreMI that the StoreMI UI is getting data from is cleared (This is some what a critical step)
  • Goto c:\windows\system32\drivers and delete the .sys files
    • rcbottom.sys ,  rcraid.sys, rccfg.sys
  • Reboot 
  • Install updated StoreMI Tool from Web

Hope this solves your issues. 

0 Likes