Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Impossible to run Adrenalin Edition Sofware after updating to 22.10.1


Since updating my graphics card driver via Adrenalin Edition to version 22.10.1, I can no longer open the application. Even updating to 22.10.2 today, the problem is the same.
I have this Windows error message if I try to open it in administrator mode (in French):


If I translate this message into English, it means:

"Lazywrite failed
Windows could not save hs file data. The data has been lost. This error may be caused by a failure in your hardware or network connection. Try saving this file to another location."

I tried to completely remove the software and the drivers then to reinstall everything, whether it was an old version or the latest version. I still get the same error message...


Configuration :

AMD Radeon RX 6950 XT MSI Gaming Trio X

Windows 11 Pro 64bit 22H2 22621.675

Radeon Software Adrenaline 22.10.2

Dell S2722DGM 2560x1440 @165Hz DisplayPort /

Iiyama PL2730H 1920x1080 @75Hz DisplayPort

AMD Ryzen 5 5600X

MSI B550 Tomahawk

MSI MPG A850GF 850W 80 Plus Gold

G.Skill Trident Z Neo DDR4 4000Mhz CL16 4x8Gb

1 Solution

@Laikikado @WildBillUK I had the same problem as both of you, and I just found the solution in a different AMD Community post. Credit to @XKwiatekX. I had been watching this post for a few months hoping someone would post the solution. In case, y'all had not found the solution elsewhere already, I thought I would reshare: SOLVED: 22.10.2 delayed write failed on Radeon Software.



View solution in original post

21 Replies

Please supply the required information:

Information Required When Posting a Discussion

Adept I

Hi There,

I have exactly the same issue with this driver (whql-amd-software-adrenalin-edition-22.10.2-win10-win11-oct) where you cannot open the AMD Adrenaline Software options!

It throws the following error:-


I have tried re-installing the driver after running the amdcleanuputility in safe mode and DDU also but the issue remains.
Only way to get the AMD options back is to do a clean install with the older driver (whql-amd-software-adrenalin-edition-22.5.1-win10-win11-may10) then the options menu opens without errors.

Windows 11 Version 10.0.22621 Build 22621 updated today.

Anyone any ideas how to fix?

@Laikikado @WildBillUK I had the same problem as both of you, and I just found the solution in a different AMD Community post. Credit to @XKwiatekX. I had been watching this post for a few months hoping someone would post the solution. In case, y'all had not found the solution elsewhere already, I thought I would reshare: SOLVED: 22.10.2 delayed write failed on Radeon Software.



OMG !!!! Thx you so much ! It's work again !!!

Glad it worked for you too!! I cant believe it was such a simple solution after trying all the regedit/ddu suggestions haha


Did you disable WU driver updates using the group policy editor before you installed adrenaline?  W11 will allow WU to replace it if you do not and this cycle will never end until you stop it from doing so which prevents it from undermining your driver install.

I did try this option and it made no difference i.e. Enable the group policy to not install windows driver updates. Reboot to safe mode, run amd cleaner utility.
Then re-install Radeon Software Adrenaline 22.10.2

After recommended restart, no ability to open the AMD options so you can adjust your GPU settings


Adept I

So, no solution at this time ?


What Antivirus software used?

Check free space at your system disk, check smart if that was SSD.

Run following commands with Administrator rights:

chkdsk c: /F /R

sfc /scannow

DISM /Online /Cleanup-Image /RestoreHealth


I use Windows Defender. Don't have any antivirus.

775Go free on my nvme M.2 ssd for windows.

I tried this commands lines and nothing else... No problems raised. The AMD Adrenalin Software doesn't work.


Something that might be worthwhile to know, is whether they are downloading direct from driver download site or using the update button in software.


Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

I can’t open the Software (this the problem raised by my question) so I download it on the website.


I always download driver directly from and not use that update thingy. If I recall right, I started doing this because I never use computer as an administrator, but a user and if I remember right, that didn't work well with update button. So... Just download from site and install. If doen't help, DDU old installation first.


I did it and it not resolve my problem...


start command prompt as admin (type cmd to windows search, right click Command Prompt, "run as administrator". 


chkdsk /F (it checks drive C for errors and fixes them if needed)


sfc /scannow (it will check and repair system file errors)

Try DDU and reinstallation now.

If doesn't work, type dxdiag to windows search, go to Display tab, write down what it says here


Then type reg to windows search, right click Registry Editor, run as administator

go to HKEY_LOCAL_MACHINE -> software -> AMD -> CN and check if this number is the same as what you saw in previous stage. If not, change it and restart computer.


If problem persists, make sure you have saved important files to somewhere outside computer and notice that changing registry like this can lead to you having to reinstall Windows:
- uninstall drivers once again
- manually delete c:\program files\AMD\ if exists
- type reg to windows search, right click Registry Editor, run as administator, scroll to top of list and click Computer, press F3 (find next), type RadeonSoftware.exe and <enter> delete each key that comes up, once you delete one, press F3 to find next, delete, press F3 to find next aso until you have gone through whole windows registry, restart, install software.

also go to HKEY_LOCAL_MACHINE -> software -> AMD -> CN and delete CN,

restart, reinstall drivers.

That is pretty much all I can think of


I just try all that step. (The CN number was the same)
and it still doesn't work...


@Laikikado1. Try to extract files manually, then run setup.exe with administrator rights.

2. Check your windows Defender for folders protection(You might turned it on).

Read this: How to Set Windows Security Exclusions in Windows 11  and Protect important folders with controlled folder access 


what files to extract are you talking about? The amd-software-adrenalin-edition-22.11.1-win10-win11-nov15.exe ? The RadeonSoftware.exe's folder ?


Those installation packages "driver-someversion.exe" are files and folder packed in to one zip file.

Sometimes when you have a .zip and just click it open it doesn't extract the files, but creates a temporary version of them and programs like this can fail, but I think it mostly just applies to .zip -files and not so much when it is a self-extracting .exe file, but you can try.

I think I would: type cmd to Windows search, right-click Command Prompt, run as administrator. Then type DISM.exe /Online /Cleanup-Image /Restorehealth to command prompt, which should check and repair different problems. More information about that

You could also run Disk Cleanup built in Windows, select system files and then click all checkboxes.

You could also download and run Windows troubleshooter, though I'm not sure how similar this behaves compared to restorehealth, so you might end up doing the same thing twice

Some things to do would also be to check registry and many others, but again... Unless you have tons of files, maybe just update BIOS if not done, reinstall Windows from USB drive, allow it to update, reboot machine, update, reboot, update, reboot, download chipset drivers from, reboot, download GPU drivers, install and reboot, check device manager to see if there are any yellow triangles and install additional drivers as needed.


I just try that solution but same problem again and again. I am desperate...
If I want to take advantage of the software, Ineed to do what I didn't want, reinstall windows... For a new computer that's 3 months old, it's frustrating...
What a bad experience for a high-end AMD graphics card...


Difficult to say what is causing that. I just built a new system and started with integrated AMD iGPU and it worked. Then, temporarily, I installed my 5700XT and drivers and that worked too.

As I read your original post, one thing came to my mind, why did you try to open it as administrator? It should run just as the user you are logged in. Maybe if you run it as admin, you actually need to be logged in as admin.

I tried and it works either way in my case. I think you might have some registry issue. One option would be to scan through registry with regedit (included in Windows), press F4 to search and search for RadeonSoftware.exe when you find it, delete it, then press F4 to find next, delete and F4 and delete and so on. Then reboot, reinstall driver.

Or reinstall Windows...