Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

High Definition Audio Controller Unable To Start; No System Audio

A few days ago when playing Team Fortress 2, which was stuttering a lot when trying to process the very high-pitched sounds in the game, my audio completely cut out. I noticed that the speaker icon present on the right side of my toolbar was accompanied by a red "X" and stated that no headphones or speakers were plugged in. They were. I restarted my PC and the issue persisted. 

After learning that this was to do with the AMD High Definition Audio Device, I had tried every possible solution. I had even reinstalled and uninstalled all of my RX470 drivers 3 times over. After further inspection, I realised that the High Definition Audio Controller had a caution sign by it in the device manager. I thought this was probably something that could be solved with updating drivers as 90% of solutions online involving the Controller and the Device was just that, but when updating its drivers it prompted me with Error Code 10 and that it was completely unable to start. I'm assuming that the High Definition Audio Controller is the cause of my computer's inability to produce sound. A lot of the solutions I've tried can't be done because of how my computer physically won't recognize that I have any audio devices plugged in/because of the Controller being unable to start.

Here are some screenshots of what some of this looks like.

Screenshot (230).pngScreenshot (231).png

Motherboard: MSI B150 Gaming M3

OS: Windows 10...

GPU: MSI Radeon RX470 Armor OC 4GB

CPU: Intel i7 6700