Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

elementary OS - failed installation, broken xserver

I would like to use Davinci Resolve. But for this I need the OpenCl functions of my AMD RX 570. I had tried to install the drivers ( amdgpu-pro-20.40-1147287-ubuntu-18.04) for Ubuntu 18.04 on elementary OS 5.1.7 Hera (bades on Ubuntu 18.04). To do this, I changed "ubuntu" to "elementary*" in the install script.

The install fails. I got error messages:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
amdgpu : Hängt ab von: amdgpu-core (= 18.40-673869) ist aber nicht installiert
amdgpu-dkms : Hängt ab von: amdgpu-core ist aber nicht installiert

The driver could not be uninstalled. Same error messages as shown above.

After a reboot no GUI was loaded.

The broken packages:
sudo dpkg --configure -a

I deleted them all one by one:
sudo dpkg -P (name)

After that the system ran again, but this cost me a lot of time.
Is there a solution that will not break my system again?

Thanks in advance

0 Replies