cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

aviato
Adept I

Drivers fault or something is burnt?

So couple of days ago i was playing league of legends and some weird texture bugs appeared in the sides of the screen but it was not the first time.After finishing the game and starting new one they were long gone.Same day and later i started playing Kerbal Space Program and by the time i played and i was closing to finishing my mission the whole system froze and screen went black.
Trying to restart it it wouldnt boot and i was getting no signal in the screen or power in my keyboard and mouse (the LEDs flashed and stayed off)
After couple of boots i got the windows repair screen but i never got it to boot.
I rebooted and i reinstalled windows on my disk moving forward i went to install the gpu drivers as my screen was in weird resolution whie my monitor is 2560x1080 and there it went... after drivers were installed black screen again.
I tried again and again with driver uninstallers and trying older drivers versions but no luck.Any time i tried to boot the screen was into 1000something pixels in size and with green lines in the monitor that appeared only in the main dektop screen (dissapeared when opening radmon apps like edge)
I have to also mention that sometimes while booting my periferals wont get any power as i mentioned before but it seems random 8/10 they will work)
but after installing the windows i get a black screen that seems to get a signal but its black.Also when the screen gets black sometimes also i lose power on mouse and keyboard.
i tried anything possible with the drivers. DDU in safe mode, older versions, newer versions...

motherboard = asrock 990fx extreme3
cpu = amd fx 6300
gpu = asus r9 270
ram = just 4gb
power supply = xfx 550watt
monitor = is a wide screen lg at 2560x1080

i knew my pc was getting old but i wanted to update it next summer since i will join the army in 4 months but i really need to run some programs for uni...
oh and i forgot for some reason i tried to install ubuntu but when it boots from the usb stick it opens the first ubuntu installer window and then the screen goes black again.

long post and i apologize but i think i tried everything with my main desktop and i cant find the cause.
Thank you in advance.

0 Kudos
6 Replies
hardcoregames_
Big Boss

Re: Drivers fault or something is burnt?

try another video card just in case your old r9 270 has bit the dust, card is over 5 years old

Re: Drivers fault or something is burnt?

It's not a driver issue. In the POST sequence peripherals are initialized after the CPU, RAM, and GPU, so a bad GPU or slot the GPU is in will halt POST there. Texture artifacts can be caused by a failing GPU but also by failing system RAM. However, losing power to the peripherals makes me think it's a motherboard issue. Try the GPU in another slot first.

aviato
Adept I

Re: Drivers fault or something is burnt?

yeah i keep my pc super clean i swear i pulled the gpu out and i was amazed how clean it still was even tho cpu started having dust.

I dont have an other card to try so propably ill buy new card and if that doesnt work ill go for new setup overall.

0 Kudos
aviato
Adept I

Re: Drivers fault or something is burnt?

unfortunately i tried the gpu in both slots that are available (the 3rd one doesnt even fit), i tried moving the ram also, changing disks and everything and the most consistent problem is that either if i install divers or when windows does it the screen goes black...i just want to make sure that the card is gone before i update because as i said ill use the system for 4 more months and then it will sit for another 9 without usage 😕

i guess my r9 will become an art in my room soon.

0 Kudos

Re: Drivers fault or something is burnt?

Your best course of action would be to get a used card for cheap just to hold you over, since by the time you come back you're looking at a complete system update, although I still have a sneaking suspicion it's a motherboard issue.

aviato
Adept I

Re: Drivers fault or something is burnt?

i found from a friend a gtx1660 to use for the next months and it worked perfectly after installing and updating windows.

Motherboard looks great still but i will be cautious on how much i overload everrything. Thank you for the replies, no more green lines and no more power loses so far.

0 Kudos