cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Can't update bios to latest version

I bought ryzen 7 5700g which should be compatible with my current cpu prime a320m-k. However I can't upgrade past 5606 and my new cpu needs bios 6042. 

I did everything I could find.

Downloaded the correct bios,

I downgraded successfully then tried upgrading again but still can't get past 5606.

Rename the bios

Fix the usb

Drink a coffee (I have to)

Eat a pizza 

Then repeat.

I'm still getting the same message. Either "The model of the BIOS image doesn't match the BIOS ROM currently present, or selected file is not currently the proper bios"

 

It's driving me nuts and my coffee is about to run out. Help

7 Replies
johnnyenglish
Grandmaster

Instead of the 6042 can you try the 6062?

johnnyenglish_0-1686778044768.png

 

The Englishman

I did that a couple of times. Tried the lower, the problem is I can downgrade all the way back to 5007 but I can't upgrade past 5606 which drives me crazy. And yes, I've download from the same website and the motherboard is correct

0 Likes

Which Windows Version do you have installed?  10 or 11?

Exactly how are you trying to update the BIOS?

If you are using a Flashdrive with the new version of BIOS is the Flash Drive correctly formatted to be compatible with flashing the BIOS?

Here are a couple of Asus Threads concerning the same issue and fixes:

https://rog-forum.asus.com/t5/amd-500-400-series/unable-to-update-bios/m-p/887040

https://rog-forum.asus.com/t5/overclocking-tweaking/bios-file-version-does-not-match-bio-rom-version...

Which Processor do you currently have installed while trying to update the BIOS?

All Asus BIOS you need to run the Renaming program first to change the BIOS file name so that BIOS recognizes it.

EDIT: Downloaded the latest BIOS Version for your Motherboard and ran the Renaming program. This is the correct BIOS name for you to update the BIOS on your Motherboard. If it is different that is your problem. If it is the same than it probably is the drive that you are using.

You can download the BIOS to your Windows Drive and try to update it from there and see if it works if the Flash Drive is not working, that is if you are using a Flash drive to store your BIOS update:

Screenshot 2023-06-18 233138.png

 

0 Likes

I have windows 10. I've already done those. I did the update through usb that I've cleaned and paritioned multiple times and yes it's fat32 and it shows that "selected file is not proper bios" even I downloaded it in the official website a couple times just to make sure. The update through ezupdate on ai suite but "The model of the BIOS image doesn't match the BIOS ROM currently present". Yes I renamed it, I tried not renaming it but still same. So after a few hours of trying all the methods I'll just give up and buy a new mf mb. 

0 Likes

Try updating through BIOS itself and not through Asus AI Suite.  IF that still doesn't work then I suggest you open a Asus Support ticket to see if your Motherboard needs to be checked.

I you already purchased a new Motherboard I would still see if your old Mobo could be replaced or repaired by Asus and then either sell it or have it as a backup.

0 Likes

I have a very similar problem with the same mainboard PRIME A320M-K.

Until this morning I had the Bios-Version 5603 and it was no Problem to upgrade it to 5606. But it was not possible to upgrade it to any version beyond 5606.
When trying to update the BIOS using EZ-Flash and an USB-Stick I get the error-message "selected file is not a proper BIOS".
When trying to update the BIOS using EZ-Flash via internet, I geht the message that the BIOS is already up to date.

I can only imagine that the newer bios updates offered by Asus are not intended for this mainboard. But why is this not communicated openly?

Perhaps this is due to the CPU: AMD A10-9700.
At
https://www.asus.com/de/motherboards-components/motherboards/prime/prime-a320m-k/helpdesk_cpu?model2...

I read

"Remove AMD 7th Gen A-series/Athlon X4 processors support since BIOS version 5862"

However this means that I need an Interim-CPU to migrate to an actual CPU.

 

0 Likes