Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

application has been blocked from accessing graphics hardware after I started using AMD gpu

I have been using Nvidia Geforce 740.

All games that I have tried on that GPU were launching fine. But new games on low FPS so I've got AMD r7 370 from my friend as a gift. I installed the latest driver (19.4.1 I guess), tried Apex Legends and it launched but since I am a noob in Apex Legends match finished in about 1 minute. When I tried to go into another match Wattman error occurred saying it restored options to default (I don't remember exact text). 

I have tried many solutions and one of them was to uninstall Riva Tunner and HWmonitor, clean uninstall my video card driver, disconnect internet, install a new driver (I choose 16.11.5 cause many ppl were saying it was stable). 

After I did that I played two or three matches in Apex Legends (total about 10-15 minute tops) when I was going for another match "application apex... has been blocked from accessing graphics hardware". I've tried scannow and some other commands that were said would fix this issue but they didn't. 

I restarted the computer, played for about 20 minutes and it crashed but this time in the middle of the game.

I restarted again and now I've been in a match for about 10 seconds or less.

I think when I restart it works fine at first but after some time something changes.

Here is a screen after the last crash: Untitled.png

Idk, can it be hardware failure? cause It seems perfect at the time when I play. Very smoth gameplay and great FPS.


I have reinstalled HWMonitor to check the max temp when the game was crashing. Take a look:


I think hardware works just fine. The driver is the problem maybe?