Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

AMD Raid Controller not working on Windows 10 Install

Hello all,

I am having issue with getting my NVMe RAID 0 array in Windows 10 install even though I am loading the driver.

The RAID 0 consists of 2 Samsung 970 PRO 512 GB NVMe drives, mounted on a Zenith Extreme motherboard flashed with the latest BIOS firmware. Used the latest download on Windows 10 ISO.

I set up my RAID 0 in the RAIDXpert Utility in the BIOS, everything looked good. I proceed with loading Windows 10 x64 Pro OS install, when I get to the drives, both NVMe's show up there.

I then proceed to load the rcbottom driver, it loads pretty fast, both NVMes dissapear ofc, then I proceed with loading the rcraid driver. It takes roughly 7 minutes to load and, to my surprise, no virtual drive is showing after it finished. I figured that maybe it also needed the rccfg driver, which I load, and still no virtual drive. If I try loading rcraid a second time, I then get a blue screen on the Windows install.

I then installed Windows 10 on my 3rd 2TB 970 Evo NVMe. After installing RAIDXpert2, the drivers get installed, I then reboot and, surprise, the RAID0 virtual drive appears, so not really sure why it won't work during the Windows 10 Install.

13 Replies
Adept I

Same problem, MSI MEG X399 Creation.  During the windows installation, I can load the bottom driver, but loading the storport driver takes forever until I get a DRIVER PNP WATCHDOG error which results in a blue screen during the windows install and a reboot.   I suspect its not playing nice with the Windows 10 1809 recovery, or maybe my configuration (1 M2 drive on the motherboard, 4 in the MSI expander card).   I've double checked all the settings (i.e. setting the m2 expander to 4x-4x-4x-4x mode instead of 16x, etc).

I am trying to setup the single M2 as a boot drive and a giant RAID 0 for the other 4 drives.

The BIOS sees the arrays just fine.  I tried leaving the 4 drives unassigned and setup just the single M2 drive as a boot drive but the storport driver install just hangs.

I can confirm what you said, I luckily had an older version ISO (1703 to be precise), and the drivers worked like a charm. The question now is, is there something wrong with the drivers that make them not work with the new Windows 10 recovery, or is the issue with the recovery itself and does not accept the drivers/mishandles them?

I believe it is getting hung trying to initialize one of the 8 storport devices.   If I trick windows into installing to the boot drive in legacy mode then do the right click inf install of the raid bottom, storport, and config drivers and reboot, the raid is visible and working, but also gets the shutdown bug where the system won't power down on a shutdown.   I was mostly interested in benchmarking the system at the time.  (x399 raid vs windows software raid vs highpoint raid card).

The first time I did this I accidentally loaded out of date AMD raid drivers, and updating the drivers in the control panel one at time was working until I hit the 5th storport device (which AFAIK was unmapped to any array or legacy drive at the time, only 0 and 1 were setup and in use at the time and updated without issue).   In this instance the device manager never returned from the install step or even timed out, and I had to hold the power button down to shut off the machine.

Hey kingfish​,

The October update you are referencing is version 1809, the issue I ( cannot say for certain if it's the same version for mrzoner​) was explaining is happening with version 1803, which is not having those problems. So the issue here is, it looks like the drivers are not fully compatible with Windows 10 1803 recovery (they have no issue with the installed Windows 10 1803), whilst they are fully compatible with the 1703 version recovery for example.

I have exactly the same issue. Unfortunately, while I have an old windows boot disk, it is legacy not UEFI.  I do not have a corresponding ISO file. I can boot from it with CSM enabled.  But while the drivers load, and the array is recognised, I then get the dreaded:

'Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk. Ensure the disk's controller is enabled in the computer's BIOS menu.'

Any suggestions?


I have solved this in a rather convoluted way, but the only way I could think of in the circumstances.  I installed Windows on a separate SATA SSD. Once installed, I was able to load the AMD RAID drivers and have Windows recognise the array.  I then cloned the Windows installation on the SSD onto the array, and then amended the size of the partition on the array.  A long way around. What is desperately needed is for Windows Recovery to properly handle the drivers in the first place.


I'm attempting similar thing, used the windows media creation tool to usb flash drive, with the amd raid drivers.  In my case i wanted clean os install, but wanted to preserve prior windows in case it didnt succeed.

I have gigabyte x399 gaming 7 F11e bios,  5 samsung (1 evo 960 and 4 evo 970) in the raidxpert (with CSM disabled now and i needed 4x4x4x4x on my pcie for hyper m.2 so i now see the raidxpert2 config bios and no nvme config) - had to actually delete the 4 raid volumes it created itself somehow, and recreate a single 4 ssd raid 0 there.    older windows was on the older ssd (no raid drivers), so i left that alone, so I could continue to boot it.   But problem comes when now trying to clean install win10 os and getting blue screen upon loading the storport raid controller driver in the newinstall/recover load drivers as the gigabyte board manual states.  it loads rcbtoom driver normal (10 seconds) goes back to screen with volumes (which all disappeared at that point), but trying f6 the load option again for the storport it shows up in list, and hangs (maybe 3 minutes) before finally blue screen or in this last case just findally came back after 5 minutes with no volumes listsed at all (we couldnt find any drives).

The first attempt was with gigabits drivers, VERSION: RC-9.1.0-00018 12/5/2017.  I then downloaded the amd version from amd site Revision:  Built date: 09/18/2018. but it's hanging the same way.  the New Windows 10 from dlc seems to have dates of 10/29/19. (whichis after the amd drivers dates, probably not relevant to the problem).   I forgot to mention I had a SATA magnetic hard drive raid 0 in there as well for data (and bios has sata raid enabled, not ahci).  I did see that blue screen with watchdog error description when the drivers failed.

It got interesting when I tried removing my prior windows ssd (evo 960), just in case it was seeing that.    suddenly it loaded the amd's storport driver, and populated the volume list, finding my unallocated 2 tb evo 970 array.  and i was able to set it for win10 and continue install.  I hope this helps other troubleshoot, but sounds like there is somethign going on with driver and backward compatiblity if it sees old windows drive.   However after it copied files, it didnt boot , purple with mouse cursor and a hang :-/  then pressed reset and it started "Getting Ready", (breathe relief). then another reboot! (holding breath for spinning circles and laughing i'm old enough to remember hour glasses and please wait messages while it takes forever to say youre good to go).  and then it says just a moment which is a good sign that you'll see the final "Hi!" and then "this might take several minutes"

After trying crystalmarks benchmark i'm only seeing 4124MB/s sequential read.. which sounds like the single drive speed of an 970evo, i was expecting at least a few times that.  switching M.I.T. misc bios setting for slots from auto to gen3, seemed to improve to 5613 read, 5159 write, i can live with that i guess, I was just trying to evaluate if raid 0 was worth the trouble (it is at least to consilidate to 2TB).

Adept I

I am having a similar problem. I have an X399 Taichi mb running the latest BIOS P3.50 The system has a Samsung 960 SSD for OS & apps and an internal RAID 0 of 4x 4TB hdds for data. Everything was working under Windows 1709. During an update to Windows 1809 the system crashed badly and was unrecoverable. I then installed Windows 1809 from a USB drive to the SSD drive. The installation went fine and the system booted but the internal RAID was not recognized by Windows.

After the fresh OS install the Device Manager showed 3 "unknown devices." When I tried to update these I was able to update the first two to storport controllers, but when I updated the 3rd unknown device the system crashed. I repeated this several times, as did a Microsoft tech support person.

I then did a clean install of Windows 1709 from my original install disk thinking the problem might be with the 1809 update. The OS installed fine and the system booted but the RAID still does not appear, and when I try to update the "unknown devices" I get the same crash.

Going into the BIOS setup, when I boot the system into RAID mode, the RAID shows up and shows the drives associated with the RAID and shows everything supposedly normal. When I boot the system in AHCI mode all the individual internal drives show up and appear to be working.

When I run a data recovery program on the system, the hard drives in the RAID show up and I can access the files on them, but the recovered files are unusable since the original files were spread across all of the drives in the RAID. All I can recover are the file fragments on each individual drive. But it proves that the drives are running and that the data is still on the drives. The problem is that I cannot get Windows to recognize the RAID.

Journeyman III

i have same problem with windows 1809
my build 2990wx
msi meg x399
4x nvme 970 pro


Old thread but its 2022 and I still have the exact same problem.


You load the drivers in ASUS Prime X570 and then you can now see the SATA raid. However the two NVME drives disappear. 


It's pretty sad they have not fixed this yet. 

I'm running latest BIOS, latest windows image, latest driver download from ASUS website. 

Journeyman III

My Rog Crosshair X670E  is not able to recognize my 4x WD Red Pro (20TB) as Raid 10 . The 4th Sata (1:1:3)  show me the hdd as  "unkown" offline. I changed the position or tried that with 1 or 2 hdds. Same problem.
I thought the 4th Sata of my MB is broken. BUT  if I use my SSD on that 4th Sata, it works. THe software raidxpert2 recognize all 4 WD Red Pro but not at BIOS/UEFI

- latest BIOS installed
- clear CMOS

- WIN 10 or 11


any suggestions / ideas?


Gigabyte B450M K with Samsung nvme.

I am also unable to load raid drivers in order to make clean install of Windows 10/11.

Doesn't matter if in AHCI or RAID mode.

Is there any way to fix this?