cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

BhavyaParekh
Journeyman III

AMD I2C Driver Issue

Jump to solution

Hi Team,

I have bough a Avita laptop which was pre installed with a windows 10 home S version and i have formatted it to a full win 10 home version but since then the touch pad does not work and i have a issue with the i2c driver which says code 10. I have tried almost every thing but cant fix it. Please help

0 Likes
1 Solution

Accepted Solutions
BhavyaParekh
Journeyman III

Re: AMD I2C Driver Issue

Jump to solution

Hi,

 

Thank you for ur reply, however the issued resolved on its own. I just uninstalled the i2c driver and shut down the laptop and turned it on in the morning and like magic it just started working

 

View solution in original post

2 Replies
elstaci
MVP

Re: AMD I2C Driver Issue

Jump to solution

Without knowing your exact Make & Model Avita laptop the only thing I can recommend is to go to Avita Support and download the AMD I2C driver from them from here: https://www.avita.com/hk/product/admiror-amd/support

Screenshot 2021-03-24 172051.png

Also it is possible that your deleted some Avita own software that your Laptop needs to run correctly. I would open a Avita Support ticket and ask them about installing Windows Home on the laptop that came with Windows S version.

EDIT: Just guessing but by your name avatar you seemed be from India. So here is AVITA INDIA where you can asked them for drivers for your laptop: https://avita-india.com/support

According to Avita Support to update Windows S to Windows Home doesn't involve formatting your laptop but seem to be a Ingrade Upgrade which keeps all the Avita Laptop Apps installed:https://www.avita.com/hk/product/admiror-amd/support

From the bottom of the webpage under FAQ:

Screenshot 2021-03-24 172051.png

0 Likes
BhavyaParekh
Journeyman III

Re: AMD I2C Driver Issue

Jump to solution

Hi,

 

Thank you for ur reply, however the issued resolved on its own. I just uninstalled the i2c driver and shut down the laptop and turned it on in the morning and like magic it just started working

 

View solution in original post