Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

AMD fTPM Causes Random Stuttering Issue

Good evening together
I wanted to ask if anyone here knows anything about the still existing fTPM Bug in Windows 11 or in Windows 10 as I have heard in the meantime.
I am affected by the bug myself and it really gets on my nerves to have to go into the bios every time I update to activate fTPM and then immediately deactivate it again so that I don't get jerks and sound problems. I have a x570 Steel Legend board with the latest bios and 32 GB Ram Trident z Royale Gold. It would be really time that one of AMD times to this but very widespread problem.
If there are errors in the text I apologize for it because I come from Germany and English is not my greatest strength.


AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC
145 Replies

I'm on the latest insider preview of windows 11 and it got a patch to fix the sound crackling which is working fine for me so far. I'm also running my x570 Steel Legend on the latest bios version i.e. Agesa and it has slowed down the random stuttering at least a tiny bit it feels. Problems still occur randomly, but to a slightly lesser degree.

AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC

I wonder at the moment how many tpm stutter users have rgb memory or rgb at all especially g skill rgb memory, if stopped using rgb software set hwinfo to poll way less often haven't experienced tpm stutter since then.


It still doesn't solve the BSOD's with no error logs that randomly happens even when running an independent module. And forget using AMD ftpm. Windows 11 is totally messed up with AMD. The only way I resolved the issues was going back to Windows 10.

Ryzen 5 5600X, MSI B550-A Pro mobo, 16GB Corsair Vengeance DDR4-3200 RAM, PowerColor Red Devil RX 6600XT video. I have experienced absolutely none of these issues since upgrading to 11 back in December. I have no RGB lighting except what is in the video card.  I don't overclock anything either. 


I wonder if this fTPM issue is also causing graphics driver timeout in several games, no matter Gpu driver version.
For. ex. Assassins Creed Valhalla and Assassins Creed Odyssey, Red Dead Redemption 2, Far Cry 6
AMD still has not solved that problem 100% and it has been for a very long time and reported multiple times.

When I read the notes from AMD about the fTPM behavior, I got suspicious:

  • AMD has determined that select AMD Ryzen system configurations may intermittently perform extended fTPM-related memory transactions in SPI flash memory (“SPIROM”) located on the motherboard, which can lead to temporary pauses in system interactivity or responsiveness until the transaction is concluded.

My rig:
Mobo: Asus ROG Crosshair VIII Hero X570
Bios ver. 4004 with AGESA V2 PI
CPU: Ryzen 9 3950X AM4 CPU
GPU driver: Adrenalin 22.2.1
O/S: Windows 10 64-bit Pro for the foreseeable future.

Best regards from Sweden


Yesterday I added the drop in TPM module on my Gigabyte X570 Aorus Master in hopes that a dedicated TPM module will take care of the stuttering issue.  I'm not happy considering how much the board cost in the first place but spending another $40 will be worth it if the stuttering never returns.

Please report back if the fTPM module works, after You have tested it for a while.

I most definitely will and surely there must be a reason that mb manufacturers have included a dedicated TPM header on their boards.  I feel better knowing that a dedicated chipset is doing the TPM work instead of something designated as a feature set as this should not be affected by bios updates.

I too am suffering from this issue... it's a pain in the rear and been a continual stream of freezes (crashes) with dump files not being readable or intelligble.

I did update my AMD chipset drivers a few days ago to the latest (4.X) and that has definitely made things a little easier and less prone to crashing, but my event viewer is stuck full of errors.
Making you look good, since the 70s...
Asus X470-I, 2700x Asus RTX2080, 32gb G-Skill, 1TB 970 Evo

I had to go back to Windows 10 without ftpm too. I tried aprox twenty OS installments and non of them worked, but I never had shutdowns or BSODs. Just Win 11 felt weird, menus not reacting, games not launching and maybe this stuttering issue. Windows 10 without ftpm feels way smoother and everything works.
I hope they can fix this, i don't want to buy a new mobo and cpu, btw next one will be Intel again for sure.

MSI Meg x570 Unify, Ryzen 9 5900X, G.Skill Trident Z K2 GSK (F4-3200C14D-32GTZ), WD_BLACK SN850 1TB NVMe, Crucial CT525MX3  500GB SSD, Gigabyte RTX 2070 8GB, Corasir 550 Watt PSU;

Moving to the stand alone TPM stopped the stuttering on my system.  My system has a 1300w PS with 6 12v rails so I don't have any power starvation issues.

Glad to hear that it worked out.

I decided today to buy a separate ASUS TPM-M R2.0 Module 149SEK (15USD).
Hopefully it will also take care of my audio crackling on my Sennhesiser (Epos) GSP670 Headset connected via USB-dongle (wireless).
Only in games and just once in a while and never a sound problem if I use my stereo speakers 2+1 (Realtek audio).

I did Not have any problem with video stutter or sound crackling before on the same system, but then I was using an older Bios version where ftpm was disabled, but with their later Bios/Agesa versions fTPM is Enabled default (preparation for Windows 11) and can't be disabled - even if I try so after reboot it is automatically enabled again.

Best regards from Sweden


I'm so glad I stumbled onto this thread (while looking at a different problem) I suspect it may just answer the frustrating problems I've been having. Am going to disable fTPM on my Win10 PC and see if the weird intermittent audio problem and lockups go away (nothing else has helped). Will update in a week or so if it works (or seems to).


@Flyfisherman Wrong. It can easily be disabled on every Asus board ever made if you know where to look.

Advanced > Tusted Computing > Security Device Support (Disable)


Just want to thank you guys. I haven't had a crash since disabling TPM on my Dark Hero, and the audio doesn't seem to be getting the weird pops and lagouts. It's made it a full week without a crash and I've been monitoring latency with LatencyMon and it's noticeably better (the high spikes of latency are about a third as high as previously). I tried a bunch of stuff over the course of two months. This is the first time I feel like the problem might actually be resolved.

Okay, today i tried a new bios update:

MEG X570 UNIFYE (MS-7C35) V10.C3 BIOS Release

1. This is AMI BIOS release

2. This BIOS fixes the following problem of the previous version:
- Update to AMD ComboAm4v2PI
- Support AMD Ryzen 7 5800X3D

3. 2022/03/23

Did not work either, certenroll event 86 error still there, but hey it's not may yet. I really hope they will fix this. Regards


Windows 11 Build 22000.651 was released to the Release Preview channel a couple of days ago, with several fixes specifically addressing provisioning TPM and Autopilot. Has anyone had a chance to see if the CertificateServicesClient-CertEnroll Event 86 persists on this build? I am on the Beta channel, so I can't easily check.

Particularly these two items from the release notes.

  • We improved the Autopilot client to process updated Trusted Platform Module (TPM) capabilities that support self-deployment and pre-provisioning scenarios.
  • We fixed an issue that prevents retrieval of the Endorsement Key (EK) certificate from the TPM device.

Waiting for a fix with this too. 


Asus has released new beta bios for TUF GAMING X570-PLUS (WI-FI)|Motherboards|ASUS Global
It has the updated AGESA Just flashed it myself and now im just waiting for a change to get some gaming time. Atleast didnt break my PC. Ive been having issues with Warzone especially, GTA V also had very bad stutter's for me. Especially waiting for the Warzone experience.

Gigabyte just released F36e with AGESA for the X570 Aorus Master which I flashed to this morning and haven't seen anything strange come of it yet.

I just commented in another thread (where I'd been trying to resolve lockups) about the 4201 Asus Crosshair VIII Dark Hero bios which features the agesa. It's made a world of a difference. I was having audio stutters (encoding sucked!) and even occasional random hard lockups while gaming (every few days).

I ran LatencyMon to get a handle on what was happening and it showed my original setup was getting huge latency 57,000μs at times. Disabling TPM in the BIOS reduced the latency spikes to around half that and managed to make the setup lockup free. The latest bios though, WOW! It's dropped the latency to 256μs. That's the highest spike I've seen in 7 hours of monitoring a variety of activities including gaming, browsing, and random work (spreadsheets, moving files, etc). The bios reduced latency to 1/200th of what is was when I was having problems.

Pity it took so long to resolve, but the fix definitely appears to work, at least for me.

edit: oh and no audio problems that I've noticed either

1207 definitely reduces performance over 1206b on X570 Xtreme. 


In one thread a user with 1207 has reported same exact behavior with 1206b and fTPM causing stutter..




Have exactly the same issue with the AGESA ComboAM4v2 PI update for my Biostar B550MX/E Pro (UEFI B55DS505.BSS)


Time to switch back to Intel...


My Theory: Different bios configurations will exploit or hide the issue, to me this is turning out to be true.  I am still running gaming tests for more data/observation but my initial finding with 1207 is fTPM Enabled + CPPC Enabled + CPPC PC Disabled + Global C-States Disabled will hide the issue.  I then ran fTPM Enabled + CPPC Disabled + CPPC PC Disabled + Global C-States Disabled.  Huge stutter.  Then fTPM Disabled + CPPC Disabled + CPPC PC Disabled + Global C-States Disabled + PSP AMD 1.0 Disabled through Device Manager and the stutter has not returned.


Can someone else verify this?





I just noticed another Users Asus PRIME A320M-K has a new BIOS that mentions it fixes the Stuttering when fTPM is enabled:

Screenshot 2022-05-21 122625.png



just tested fresh gigabyte x570 aorus elite bios (f37c) with AGESA

and...problem is not fixed. still have stutters.

It might not be a AGESA issue since the BIOS mentions only that is it for better compatibility for newer Ryzen Processors.

Since other have updated to the same AGESA Version as Asus without a fix.

But It mentions specifically about fixing the fTPM stutters.

Maybe someone can contact Asus to find out if the fix for the fTPM stutters is due to a new AGESA version or some other BIOS setting that was updated.


i contacted the MSI support two times now and they have no clue when the new update will be released. and now the news, that it will not even be fixed after the update makes me crazy. isn't that a case for rma? future will be intel only.

Meg x570 Unify, Ryzen 9 5900x;

Got Ryzen 9 5900X and MSI MAG B550 Tomahawk mobo. fTPM issue is fixed for me in AGESA BIOS version 7C91vAA1(Beta version) from 2022-05-26. Was sitting with fTPM On for a week and no stutters what's so ever. Actually it doesn't matter what BIOS version you got. Stutters vanish on any BIOS version when you turn this useless fTPM  option off. Generally, I don't understand why do you need this fTPM feature on a desktop PC? Maybe only for getting Win 11 installed and to encrypt drives with BitLocker? BitLocker is useless crap full of backdoors. Better use VeraCrypt. It is open source (i.e. safe), much more flexible and user-friendly and doesn't require fTPM.

Intel's 12k series CPUs maybe slightly better by means of performance but power consumption is beyond common sense. I understand why Intel came out with this Efficient/Performance cores separation BS instead of making all cores to more efficiently adjust their performance and power draw on-the-fly like AMD did. This because they (Intel) messed up with technology process and got left behind AMD in this sense. Larger and older technology process means higher power draw. So it's up to you to decide.


While I haven't upgraded the BIOS on my Gigabyte X570 UD v1.1 motherboard with 5600X processor beyond the original factory installed F34 firmware, I took the advice from the Gigabyte technote on this issue and preemptively installed a hardware GC-TPM2.0_S  module to avoid the whole fTPM drama.

Intermittent System Stutter Experienced with fTPM Enabled on Windows® 10 and 11 

You can find these being sold in bulk on Amazon as single units for around $39 shipped. 


Until now, the issue did not reoccure. Did not use the machine very long the last days, so might not 100% be shure. But clearung the TPM with the TPM Manager in combination with the ViveTool command seems to have it fixed. But we will see. AGESA was not in the update from MSI - it was first shown as an Update in the current UEFI version, but now there is only listed that Secureboot is enabled by default


Without new agesa and discrete tpm chip i could still get tpm stutter every 2 months its always exactly either once a week once a month or every 2 months, already on latest bios, if experienced garbled sound still once instead of a stutter, so it does not look like its fixed yet, it just sounds different while it now only effects sound.


Installed BIOS 2.32 Asrock B550m PRO4. Now looking for stutters.


7 days with fTPM enabled without issues. I will continue to look if it lag, but for now it is good sign.


I have the same Motherboard with the latest update F37d. I have still symptoms. Did it fixed on your PC with this update?


So after more testing, my huge stutter from the one bios configuration was not fTPM stutter but due to internet traffic congestion with online game-play.  Still not ruling out fTPM issues yet but the extensive observation exploited other issues.  Confirmed the traffic congestion with Ping Plotter to the game server. 




Hey, whats going on?

Really I have not before mounted a fTPM dercrete and setup in my BIOS > Discrete fTPM
And I can't even  say  what is what.




I wonder how many people with fTPM related stutters are running  ASRock motherboards..?

I am currently running 4 ASRock AM4 motherboards without issue under Windows 11

5900x & x570 Taichi

5800x & x570 Steel Legend

5600x & B550m Phantom Gaming 4

3700x & A520-HDV

All have 32GB of RAM, all have latest BIOS's (did not have stutters on previous BIOS's either).. all Air cooled

ThreeDee PC specs
Journeyman III

X570 Aorus Xtreme (Ryzen 3950x) with BIOS F36c (AGESA does NOT fix the issue for me, still exact same symptoms and frequency as before with under 2 seconds of freezing and audio corrupting/cutting out. Problem began ever since Windows 11 and toggling fTPM in BIOS.

Really disappointed, hoping this is the result of BETA BIOS/AGESA and not the so called final fix. All troubleshooting has been carried out and the CMOS fully cleared to ensure a clean slate.

If they can't fix this then there can be a hardware flaw with some Ryzen processors, as it would not make sense for it to be a motherboard defect due to the fact that a defective BIOS SPIROM would be easy to spot and would cause other operational issues. It’s clear that the Ryzen PSP/fTPM is heavily broken with probably many issues at play, judging by how some people report fixed, others not fixed.

I am planning to upgrade to a 5950x soon and will know if replacing the processor fixes it, if not, I will get a discrete TPM to work around it. This is still very disappointing and has me heavily favouring Intel for my next high end build, unless they can fully resolve it.


@rob-techI also have an X570 Xtreme Rev 1.0  I wonder why I am not seeing it and you are.  I am using a 1 ccd chip however and I did have a 3800X, then went to a 5800X, then a 3D.  Game smoothness did get better from the 3800X to 5800X