cancel
Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

geojoek
Journeyman III

Can't get image displacement to work in ProRender 2.4 + Blender 2.83

Howdy,

I can't seem to displace a plane with an image texture in ProRender 2.4 using Blender 2.8x.  I've tried this across 2.8x versions and different computers / graphics cards.

My shader settings are attached as a PNG-- they work in Cycles (result attached) but ProRender either produces a flat, blank, grey plane with tiled rendering turned on, or exits with "ERROR | RPR ContextRender returned error code <-3>" with tiled rendering turned off.  Screenshots of both are attached.

I'm presuming there is something fundamental I'm missing: I'm using a 16-bit unsigned TIFF as a displacement map.  Does ProRender work with images as displacement maps and, if so, are there specifications for the files it can use?

Running this particular test on MacOS Catalina 10.15.5 with a Radeon RX Vega 64 via an eGPU, 8gb VRAM though I've gotten the same results across different systems with different hardware.


Thanks!

0 Likes
6 Replies
arozghon
Challenger

Re: Can't get image displacement to work in ProRender 2.4 + Blender 2.83

Hello! thank you for request, could you share the scene or tiff file from this scene to complete correct investigation of your issue. Thank you

0 Likes
geojoek
Journeyman III

Re: Can't get image displacement to work in ProRender 2.4 + Blender 2.83

Of course!  Scene file and the tiff in question are attached.

0 Likes
geojoek
Journeyman III

Re: Can't get image displacement to work in ProRender 2.4 + Blender 2.83

Somehow when I added the scene and TIFF arozghon‌'s comment got deleted... apologies!

0 Likes
arozghon
Challenger

Re: Can't get image displacement to work in ProRender 2.4 + Blender 2.83

Thank you!

0 Likes
geojoek
Journeyman III

Re: Can't get image displacement to work in ProRender 2.4 + Blender 2.83

Just curious-- were you able to replicate, or find a solution to the issue?  I've had no luck on my end...

0 Likes
arozghon
Challenger

Re: Can't get image displacement to work in ProRender 2.4 + Blender 2.83

so, after a short investigation, I find one issue: RPR displacement does not support your attached tiff file. when I convert a tiff file to PNG - all works as expected and imported other TIFF file show results. need to find out the reason why the TIFF file not supported by RPR. Thank you for reminder 

0 Likes