vasilisk

Sapphire RX 5700 XT nitro + Crashes after ~20-30 seconds after a game launches

Discussion created by vasilisk on May 20, 2020
Latest reply on Jun 4, 2020 by vasilisk

This is the first time I have to write into a forum for a solution and I am really frustrated because of this negative experience with this GPU. So after new pc build and clean install of the drivers using DDU and AMD tool as well in safe mode, when I launch a game doesn't matter what game (tried pubg, lol, csgo)  after a short amount of time ~ 30 seconds my pc flashes a green screen making a weird "trrrr" noise (not always) and reboots. I tried the FurMark stress test and works fine. when I try a game it almost instantly crashes. 

 

The weirdest thing that has happened 2-3 times is after a lot of tries and clean install of drivers is that it works but only as it keeps open when i shutdown or restart back to reboot crash without any error codes.

Things I tried:

  1. Install drivers with and without adrenaline.
  2. Multiple versions of drivers.
  3. Single PCIe cable and 2 PCIe cables from PSU.
  4. Update All drivers chipset etc.
  5. When drivers install with adrenaline disable everything from it in general settings
  6. PCIe set to 3.0 from 4.0

 

My setup 
OS: Windows 10 Pro Version 1909
GPU : Sapphire RX 5700 XT nitro +

CPU : Ryzen 7 3800x

MOBO: Gigabyte X570 Gaming X

PSU: TX 750 M 80+

NVMe: Samsung 970 500gb 

RAM:2x 16gb Corsair 2400mhz 

 

I am attaching the dxDiag result bellow as well.

 

Please Help.

Attachments

Outcomes