AnsweredAssumed Answered

Ryzen 3950x, Motherboard (x370 taichi) or AGESA Faulty? (fail prime95 small fft at stock (auto)), random reboots, bsod

Question asked by demonak on May 15, 2020

Hello

So, i bought ryzen 3950x for replace my old 2700x stable processor and after two weeks i saw random reboots, all setting stock (auto). Then i decided test new PSU and same issue. Replaced new kit 4x32gb F4-3200C16Q-128GVK (tested without xmp) to old 4x16gb M378A2K43CB1-CRC and same problem (all memory kits working fine with ryzen 2600, 2700x). Then after couple tests i found what prime95 small fft fail emideatly after start, some thread not running and sometimes i got bsod and the other stress test OCCT power with avx2 shows many errors after start.

Ok i decide to replace CPU in store, because i think it's faulty / defect and when i recived new one after one month, install and test prime95 small ffts and know what? problem still happend, not running thread and bsod. I Testing many bioses for my board: 5.80, 5.91, 5.93, 5.94, 5.95, 5.99, 6.20, 6.20A, 6.20B, but the problem is not solved. ASRock support not helped, they tested them cpu ryzen 3950x on same board x370 taichi and not could reproduce problem.


I Found solution on internet forums: set cpu offset voltage +0.05v with LLC2(3) or enable PBO (can too hot and throttling) all stable right now and prime95, occt pass without errors and bsods.

 

But i Want know i recived another defective CPU? or perhaps this is motherboard problem (too much drop voltage on very high cpu load) and i need to return money (because board still under warranty) and buy example new motherboad on x570 or maybe it's bug in AGESA code because i see many other post with the same problem on differents system configuration like x370, x470, x570 + cpu ryzen 3600-3950x. Why I didn’t have problems on processors ryzen 1700, 2600, 2700x?

Just thinking ... maybe after some BIOS/AGESA update on the processors ZEN2 the voltage in the load is too low or idle and this leads to problems like random reboots, bsod.

 

My Specs:

* CPU: ryzen 3950x(batch 2008)
* Cooler: noctua nh-d15
* MB: Asrock x370 taichi (bios 6.20)
* DRAM: 4x32gb G.Skill F4-3200C16Q-128GVK
* GPU: Palit GTX 1080ti JetStream
* SSD: SAMSUNG 960 EVO MZ-V6E500 500gb, M.2 2280, 1tb HP EX950
* hdd :Toshiba 2x3tb (DT01ACA300), Hitachi 1x3tb (HDS723030ALA640), Seagate 1x3tb (ST3000VX000), 1x8tb Hitachi (HDN728080ALE604), 1x10tb Toshiba (MG06ACA10TE).
* display: BenQ XL2420T 1920*1080 120hz
* case: lian-li v2120
* PSU: Thermaltake TP DPS-G 850W:
+3.3V - 25A, +5V - 25A, +12V - 70.83A, -12V - 0.8A, +5VSB - 3.0A | +3.3+5V (130W), +12V (849.96W), -12V (9.6W), +5VSB (15W)

Outcomes