AnsweredAssumed Answered

GPU usage spike to 100% then black screen... at idle

Question asked by manyregrets on Oct 8, 2019
Latest reply on Oct 17, 2019 by manyregrets
  • Issue Description: Intermittent black screens that crash games. Radeon Settings window blurry bug that requires restarting the program.

I have been having this issue for several months now, I am not sure exactly when or how it started. Screen will freeze for a second or two, then the signal is lost for a very short time (1-2 seconds usually), followed by the screen returning to normal. It will also crash any game currently running, or, the game will continue running but will no longer display and cannot be brought to the front as it is no longer displaying at all (GPU usage at idle with game permanently not displaying).  The Radeon Settings window will almost always be blurred when I attempt to open it, and will also become blurred and transparent again after this screen issue presents. This can happen twice in 10 seconds or every few minutes. 

 

This issue happens usually within the first hour (or during the first hour) that the computer is running. Temps are normal and voltage isn't elevated that I can tell. There has been no hardware changes for well over a year and I generally only update Windows and graphics drivers, I try not to touch anything else. Not overclocking an play a variety of games, which any will trigger this event. 

 

Another strange thing is that this screen black issue will plague me for some time (up to an hour but usually around 20-30 mins) and then will stop. I can put my PC through the ringer and play intensive games after it stops and I will have no issues. But it will return once reboot or turn on my PC. So far there have been several posts on various forums I have found with similar (or perhaps the same) issue but many of them don't have solutions found or suggested. I have tried updating and also clean installing drivers, rolling back and then getting the latest. Since I started rolling back and trying newer drivers the issue is more prevalent and now happens when browsing the web using chrome (simple webpages with images, such as arts and crafts pages).

 

Windows taskmanager will report that when these freezes and black screens happen, GPU usage spikes to 100% for that second, then back to normal. The process using 100% wil be the game, or Radeon settings, or even nothing at all. I have seen usage at 100% and the only program using it at 1.8%. Further into taskmanager it seems the 3D graph shows the usage at 100%. Process Explorer shows something similar. BTW I'm not using FreeSync. 

 

When it crashes games, the error codes usually point to one of the following things:

 

- Vulkan is missing/corrupted or something related to that. (X4: Foundations) 

- D3D something or other has failed/missing (can't recall what it was exactly but that was Unreal Engine 4)

- OpenGL stuff has soiled the bedsheets (Radeon Settings window having a tantrum, snip attached with blurry transparent screen behind it)

 

  • Hardware: Alienware X51 R2, RX480 GPU (blower), increased PS, SSD.

 

  • Software: Windows 10 64-bit, Radeon Software 19.9.3 (have also tried 19.8.2; 19.5.2; 19.7.1; 17.10.2; and 17.7.2)

 

I am recently started using Process Explorer and Afterburner but nothing seems to have changed. Also trying Wattman but so far nothing.

 

Sorry for the wall of text but this issue is wasting much of my free time and causing much grief and distress. Thank you.

 

Update: When BSOD occurs, i get the Video_tdr_failure (atikmpag.sys) error screen. (Hope that helps)

Attachments

Outcomes