AnsweredAssumed Answered

DX Error Causing Game not to Start

Question asked by cimamura on Oct 7, 2019

Specs
Intel Core i7 5820K 3.30GHz
16GB ram
AMD Radeon R9 Fury X 19.9.2 WHQL Driver
Windows 10 Home 1903

 

Hope Im in the right forum....

 

I play a flight sim IL2 - Battle of Stalingrad, and back on Aug 28th, I updated to Windows version 1903, from 1803. I didnt think nothing of it until I tried to play IL2, havent played the game for over a month now, and get this....

 

DXBufferMan11::vb(..)

DXGI_ERROR_DEVICE_REMOVED (0x887a0005)

 

I have searched everywhere, tried so many uninstalls/reinstalls, the regedit thing, rolling back drivers, updating drivers, reinstalling drivers, scan disk, reinstall DirectX, and so on and so on. My poor computer cant take it.

 

Has anyone with an AMD card, not an Nvidia (this error seems popular on those cards) had this and successfully fixed it and was able to get it to work?

 

Thanks.

 

PS: This is what IL2 support officially sent me after I sent them dxdiag, tasklist and msinfo, obviously, they have no clue as to how to fix this. Waste of time really, seems like im talking to Microsoft on their forums.

 

Dear user,

 Try the following steps: - to introduce the game to the exceptions list security features or to disable them. - disable the Programs that use your video adapter in parallel with the game and utilities from the Manufacturer. For example, we have feedback from pilots who have had similar problems. They claim that some of these utilities have had a negative impact on the stability of the Game. - re-Install the drivers for your video card , It may make sense to try earlier versions of the Driver. - exit/disable all unnecessary processes.   take a look at this article: http://support.microsoft.com/kb/929135/en-us

http://support.microsoft.com/kb/815069/en-us

Attachments

Outcomes