devilblackdeath

Impossible to install B450 chipset drivers since the new installer and version numbering

Discussion created by devilblackdeath on Sep 27, 2019
Latest reply on Nov 18, 2019 by ghostryderflyby

Hi everyone,

I wanted to update my chipset drivers recently and saw that since my last update (around may I believe) there was this new installer and version numbering used.

Sadly when I try to run the update, it gets stuck on the drivers extraction and used 5Mb of RAM, and no CPU usage or disk usage (or 0.1% CPU and 0.6Mb/s of disk writes for about 5-10s then nothing). Nothing gets extracted to the AMD folder at the root of any of my disk drives.

I tried removing the content of the AMD folder in question, I tried moving the installer to each HDD and running each from each, none works, and I tried completely uninstalling the existing drivers and install these either from scratch or from the latest of the old numbering. I also tried either installing the first of the new numbering or the latest. Lastly I also tried both official AMD drivers and the drivers available on the website of my mobo (Strix B450-F Gaming). I pretty much tried everything people tried when having the same issue with the old drivers (early 2018 apparently).

Nothing works and I'm at a bit of a loss. I don't even understand why they changed their installer. Sure the old one didn't look super pro during the extraction process, but the new one with the Windows Form window that's probably from the C# libraries isn't great either... (doesnt even have a custom icon :S)

If anyone knows what I can do about it thanks in advance.

Outcomes