r3f3r1

Ryzen 7 2700X ...issue?

Discussion created by r3f3r1 on Sep 22, 2019
Latest reply on Sep 23, 2019 by cosmicdance

Hi everyone! I just recently put a Sapphire Pulse 5700XT GPU in my PC to go along with my Ryzen 7 2700X CPU. Upon doing this I decided to update AMD chipset drivers and my BIOS as well to get everything up to the latest versions because why not? Specs are as follows:

Ryzen 7 2700X

Thermalright Macho X2 cooler

Asus Prime X470-Pro

G.Skill Trident Z 16GB

Sapphire Pulse 5700XT

EVGA SuperNOVA 650W G2 PSU

500GB M.2

1TB M.2

1TB HDD

2TB HDD

2x 250GB SSD

I don't overclock my Ryzen 7 2700X, but upon running Ryzen Master I noticed something different than when I previously ran it. EDC (CPU) is always 100 % of 140 A and the Core Speed NEVER fluctuates from 4075 MHz. Do I have a setting that is wrong somewhere in Windows or the BIOS? I thought before I updated everything my CPU would fluctuate and idle at 3.7 GHz at times and boost upwards of 4.3 GHz, but now it literally never moves. I loaded optimized defaults in BIOS and the only setting I changed in there is my memory frequency which I changed to DDR4-3000. I am running the latest version of AMD chipset drivers v1.8.19.0915, the latest Adrenalin drivers for the GPU 19.9.2, the latest version of Windows 10 Pro (v1903) with all updates, the latest BIOS version for my motherboard (Version 5216) and my power plan in Windows is set to Balanced. Any ideas on why I am seeing this behavior? Any suggestions/recommendations?

Attachments

Outcomes