AnsweredAssumed Answered

Problemas con la aceleración 3D

Question asked by deskrub on Aug 13, 2019

Buenas! Escribía por un problema que me ha surgido con los gráficos 3D. Os pongo en situación:

Tengo un HP Pavilion DV6 6196ss, del 2011 (troncho de tiempo ya pero va fetén). Tiene doble gráfica, una Intel HD Graphics 3000 y una Radeon HD 6770m, de 2Gb dedicados. Os dejo el pastebin del msinfo de la pantalla y la información del sistema del dxdiag.

 

https://pastebin.com/ePHRbJY6 

https://pastebin.com/Hdhp9pnk 

 

Pues la cosa es que, antes de actualizar Windows 10 a la versión 1903, estaba jugando sin problemas al Dragon Age Inquisition y al WoW:BfA, tirando de la gráfica AMD. Rendimiento de lujo y echándole tela horas.

 

Ahora bien, al actualizar Windows (o al menos ocurrió algo en el mismo espacio temporal), no me dejaba entrar a ninguno de los dos juegos por problemas de la aceleración 3D ("World of Warcraft no funciona con tu tarjeta aceleradora 3D"). Sin embargo, a otros juegos como el Minecraft o los Sims 4, no hay problema (no he probado en más).

 

Apunto que, con el WoW, puedo jugar si uso la gráfica Intel. Pero, claro, va notablemente peor.

 

He mirado mil posts que tienen muchas de cosas en común. Por lo pronto, he hecho:

- Instalación limpia de los últimos drivers que da AMD, hasta la versión Crimson:

Radeon Settings Version - 2016.0226.1531.27895

Driver Packaging Version - 15.301.1901-160226a-318062E
Provider - Advanced Micro Devices, Inc.
2D Driver Version - 8.1.1.1533
Direct3D® Version - 9.14.10.1171
OpenGL® Version - 6.14.10.13417
OpenCL™ Version - 2.0.4.0
AMD Mantle Version - 9.1.10.99
AMD Mantle API Version - Not Available
AMD Audio Driver Version - Not Available.

Comprobé que no habían más actualizaciones por el Administrador de Dispositivos.

- Intento de instalación del último Directx que da Microsoft, que no terminaba la instalación porque decía que ya tenía el Directx actualizado.

- Instalación del paquete de Directx de Microsoft End-User Runtimes (June 2010).

- Instalación del paquete de C++ que aporta Microsoft.

- Cuando accedo por Configuración>Sistema>Pantalla>Configuración avanzada de pantalla>Propiedades del adaptador de pantalla me sale la Intel y no puedo cambiar nada de la aceleración de hardware.

- Ni en Crimson ni en el Catalyst Control Center me salen opciones de la aceleración de hardware.

- Reinstalación del WoW.

- Restaurar el sistema a un punto anterior a haber actualizado Windows a la 1903 (solo sirvió para perder el tiempo).

- Tras restaurar, actualicé Windows a tope y volví a hacer una instalación limpia de los drivers, de los Directx, del C++ y del juego.

- Tras todo esto, pude notar que también había perdido bastante pelo.

 

Estoy sin muchas ideas sobre qué hacer. Echadme una manica, por favor.

 

Muchas gracias por vuestra atención, y perdonad si se me ha olvidado algo o soy un brasas.

Outcomes