zinx

Vulkan Issues - bad tearing and AMDVLK driver issue

Discussion created by zinx on Jun 14, 2019
Latest reply on Jul 30, 2019 by zinx

Hello.

I am here to discuss 2 problems that I got with using the Vulkan API on both Windows and Linux OS.

First issue:

I have a problem using Vsync with games/softwares that use the Vulkan API.

Software like Dolphin,PPSSPP and RetroArch get constant tearing issues that I dont get with other API's like Directx 11 or 12.

I am using a Dell Inspiron 17 5000 series.

It's using the AMD GPU Radeon 530 and the Intel GPU Intel UHD 620.

The OS is Windows 10 and the CPU is Intel i7-8550U.

The developers of Dolphin believe it's a driver problem and not a software one.

Here is the bug on their issue tracker : https://bugs.dolphin-emu.org/issues/11674.

I tried to force vsync from AMD settings and it didnt work as well.

Second issue:

I cannot use the AMDVLK driver using Ubuntu 19.04 OS.

The driver refuses to work correctly and displays garbled graphics output as a result.

I already opened an issue on the github repo but no one fixed it yet:

https://github.com/GPUOpen-Drivers/AMDVLK/issues/72.

Thanks.

Outcomes