0 Replies Latest reply on Aug 13, 2018 12:10 AM by lawlman

    Urgent help! Black screen after turning on game mode in Ryzen Master, PC wont boot

    lawlman

      Hello. Last night I decided to test out the game mode profile in ryzen master utility, and now it seems that my PC wont even turn on. I'll describe in detail what took place.

      I had turned the game mode on and click the apply setting, it asked me if I wished to restart since it had to turn "Legacy Compatibility Mode" on. I of course clicked restart and it did it's thing as usual. Though when it tried to reboot, it didn't. It shut itself off and back on again three times over before turning on and staying on with my MB's cpu warning light totally on. It still remains like this when turned on, it also switches inbetween the ram and the CPU light but only for a split second. It remains mostly on the CPU light.

      Whenever I try to turn the computer on, it remains at a total black screen BUT still on. No bios, no anything at all. I cant do anything but unplug things and turn the system off and on yet the fans are on and everything seems operational, even the gpu. I've already tried resetting the CMOS using the jumper pins(though not the plastic jumper, only a metal screwdriver as my mb's manual said.) And also pulling out the cmos battery entirely. It does nothing. I feel like im totally out of options here. If I really am out of options, what do I do?

      Here's my full system specs: https://pcpartpicker.com/user/Lawlman/saved/Wjh23C