AnsweredAssumed Answered

Witcher 3 - 3x Crossfire R9 290X - only utilizing 2x GPU

Question asked by snowfan84 on Aug 1, 2017
Latest reply on Aug 24, 2017 by snowfan84

Have been experiencing sever crashes with Witcher 3 - The Wild Hunt GOTY ediiton (GOG).  These cause the last half second of sound to loop, the keyboard mouse and screen are unresponsive.  The only way out is to hard power the PC via the power button.

Investigating this, I started playing with the WattMan settings in the AMD control panel.  Turning on the histogram, I noticed this game is not loading the 3rd GPU.  Testing this, I loaded another title Dragon Age Inquisition and found it is fully loading the 3rd GPU.  See attached screenshots.

 

This explains why there is stuttering in Witcher 3 while Dragon Age is smooth.  I found it only to act this way with the 'Use AMD pre-defined Profile' and selecting 'Witcher3Arabic.exe'.  From there I proceeded to test all the other crossfire profile options -

- AFR Friendly - fully loaded all GPU and the framerate is good but there is flickering all over - unplayable

- Optimize 1x1 - does not fully load any GPU and framerates are very bad

- AFR Compatible - does not fully load any GPU and framerates are very bad

 

Windows 10 Pro x64 - New Install

Intel I7 4930k 6-core CPU

ASUS Rampage IV Black Edition

GSKILL 64GB DDR3 RAM

XFX R9-290X-ENFC (quantity 2)

ASUS R9-290X (quantity 1)

EVGA SuperNOVA G2 1300W PSU

Radeon Software Version 17.7.2

 

There is no overclocking configuration anywhere in the system.

It seems this is a problem with the AMD pre-defined Profile for this title.  Is there anything that can be done?

Outcomes