0 Replies Latest reply on Jul 25, 2017 1:52 PM by qrand

    EEPROM not present

    qrand

      I have several servers with S7150 FirePro cards. Most work fine. Three won't update PLX firmware.

      In RHEL 7

      # ./atiflash -i

      adapter bn dn dID       asic           flash      romsize test    bios p/n
      ======= == == ==== =============== ============== ======= ==== ================
         0    03 00 6929 Tonga           M25P40/c         80000 pass 113-C7630700-100
         1    05 00 6929 Tonga           M25P40/c         80000 pass 113-C7630700-100

      # ./amdgflash -i=0 -plx_write=113-8747CA-200.bin -f

      AMDGFLASH version 0.3, Copyright (c) 2016 Advanced Micro Devices, Inc.

      Old Firmware Ver : N/A
      New Firmware Ver : 113-8747CA-200

      Errors detected while writing to PLX EEPROM.

      # cat TOOL.LOG

      [215:121] (Error) CPLXControl::WriteEEPROMDword() - timeout waiting for transaction complete.

      [215:121] (Error) CPLXControl::WriteEEPROM() - failed to write to EEPROM at offset 0x0

      # ./amdgflash -i=0 -plx_status

      AMDGFLASH version 0.3, Copyright (c) 2016 Advanced Micro Devices, Inc.

      [0] VendorID: 0x1002 DeviceID: 0x6929 SSID: 0x0334 (03:00.0) (C76307-FGL TONGA)
      -------------------------------------------------------------------------------
      PLX EEPROM not present.

       

      Since the card is detectable it seems unlikely that the EEPROM is missing. An internet search hinted that a jumper might be missing. I don't want to remove the cover unless necessary.