3 Replies Latest reply on Aug 1, 2017 9:29 AM by amdmatt

    Latest version of AMD Crimson deactivating itself.

    agucova

      I have a HP Pavilion AW002LA laptop, which has the following specs:

      CPU: APU AMD Quad-Core A10-9600P (2,4 GHz, max 3,3 GHz, 2 MB cache)

      Memory: 16 GB of SDRAM DDR4-1866 (2 x 8 GB)

       

      And more importantly, graphics:

      AMD Radeon™ R5 Bristol Ridge (512mb DDR4)

      AMD Radeon™ R7 M440 (4 GB DDR3 dedicated)

       

      I've been having several problems with the stock driver provided by HP, so I tried to install another one using the latest AMD Crimson (17.4.4, automatic install), but it fails with an unknown error on device administrator, making Windows use the basic display driver. Checking on other forums with the same model seems to show that this is a fairly common problem with this laptop. As a note, in device administrator it shows the dedicated card as a R7 M340, when it should be a R7 M440

      K1RC3TX.png

      I've reinstalled the system, updated windows and even tried using a usb recovery kit but it doesn't seem to properly detect the cards. I've also tested older versions of AMD Crimson without any luck.

       

      The performance with HP's stock driver is really awful on any game. Even just plain minecraft runs at 15-20 fps (only showing the integrated card).

       

      Any idea on how to do diagnostics or maybe report the bug to AMD?

       

      EDIT: More images here.

      EDIT2: When trying Crimson 17.4.3 all games look glitchy (can't see anything, images here).