2 Replies Latest reply on May 3, 2017 11:58 AM by achossa

    ME:A can't launch, new win update same problem

    achossa

      It's this again. New windows update clashes with AMD drivers again.

      Can't launch ME:A again, please fix it.

       

      Radeon Software Version - 17.4.4   the same with 17.4.3

      Radeon Software Edition - Crimson ReLive

      Graphics Chipset - Radeon (TM) RX 470 Graphics

      Memory Size - 4096 MB

      Memory Type - GDDR5

      Core Clock - 1242 MHz

      Windows Version - Windows 10 (64 bit)   1703 os build 15063.250

      System Memory - 8 GB

      CPU Type - AMD FX(tm)-6300 Six-Core Processor

       

      Radeon Settings Version - 2017.0316.1721.29397

      Driver Packaging Version - 17.10.1731-170424a2-313603E-CrimsonReLive

      Provider - Advanced Micro Devices, Inc.

      2D Driver Version - 8.1.1.1599

      Direct3D® Version - 9.14.10.01261

      OpenGL® Version - 6.14.10.13474

      OpenCL™ Version - 22.19.162.4

      AMD Mantle Version - 9.1.10.0189

      AMD Mantle API Version - 102400

      AMD Audio Driver Version - 10.0.1.1

      Vulkan™ Driver Version - 1.5.0

      Vulkan™ API Version - 1.0.39

       

      Graphics Card Manufacturer - Powered by AMD

      Graphics Chipset - Radeon (TM) RX 470 Graphics

      Device ID - 67DF

      Vendor ID - 1002

      SubSystem ID - 3411

      SubSystem Vendor ID - 1462

      Revision ID - CF

      Bus Type - PCI Express 3.0

      Current Bus Settings - PCI Express 2.0 x16

      BIOS Version - 015.050.000.000

      BIOS Part Number - 113-V34111-F4

      BIOS Date - 2016/11/21 21:06

      Memory Size - 4096 MB

      Memory Type - GDDR5

      Memory Clock - 1650 MHz

      Core Clock - 1242 MHz

      Total Memory Bandwidth - 211 GByte/s

      Memory Bit Rate - 6.60 Gbps

      2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0000

        • Re: ME:A can't launch, new win update same problem
          adamd16

          I've been able to play ME:A with MSI RX480 8GB with AMD drivers 17.4.3 perfectly fine on windows version 1703 (OS Build 15063.250 (Creators update)) without any issues. I suggest you download Display Driver Uninstaller - Display Driver Uninstaller (DDU) V17.0.6.4 Released. - Wagnardsoft Forum (here is the latest version I think) and perform fresh install of latest amd drivers. It's worth noting it would be very helpful if you can do dxdiag in run.

           

          Windows key + r for run then type dxdiag, this will tell myself and others if this is an issue with your drivers or configurations within Directx

            • Re: ME:A can't launch, new win update same problem
              achossa

              Hey, It worked. I was reluctant to do it at first, due to the system restore points and other stuff.

              However, the process is rather straight forward and simple. Oddly enough, it worked after a second

              run of the process because I forgot to run dxdiag at first.

              Anywho, ME:A works, Dragon's Dogma runs, Age of Barbarian runs, MKX was acting up on me, but that's a low priority at this time.

              edit: I've actually recently installed an RX470 (just a few days prior to the creaters update from win10)

              from previously having an HD7700. I've had a years worth of AMD drivers for catalyst and crimson in my AMD folder.

              I've cleaned all that with the DDU.

               

              Thanx Adammd16

               

              dxdiag attached below