2 Replies Latest reply on Mar 5, 2017 10:46 AM by kodek

    rx470 - "No AMD Graphics Driver Installed" after reboot or two.

    kodek

      So I have asus strix rx470 for few moths now. Today It loaded like usual, native resolution (But stuttery system), except I couldn't hear any sound (I use sound over displayport). Windows reported, that no audio device is connected, and finally opening AMD radeon settings resulted in "No amd graphics driver installed or is not functioning properly. Please install the AMD driver appropriate for your AMD software"

      So, what I did so far:

      1. Uninstalled AMD software from settings
      2. installed it back from included CD, updated everything.
      3. Rebooted system, only to see that error one more time

      (2nd round)

      1. I used clean uninstall, reboot, install drivers, update, fail.

      (3rd round)

      1. Dism /Online /Cleanup-Image /CheckHealth (No errors found)
      2. Dism /Online /Cleanup-Image /RestoreHealth
      3. sfc /scannow (No system integrity violations found)
      4. Removed drives using Display Driver Uninstaller in safe mode
      5. reboot
      6. Repeat points: 1, 2, 3
      7. Installed compatible drivers from AMD website.
      8. reboot

      So it worked, reached 56fps score in The rise of the tomb raider benchmark, and then after shutting down, BOOM! "No AMD graphics driver installed or is not functioning properly. Please install the AMD driver appropiate for your AMD software"

      Side notes: During last reboot it took longer for bios to post (felt like 10 sec?), and taskmgr reported that last bios time took several billion years.
      Full system spec:

      System: Windows 10 1607

      CPU: Intel I5 6400

      GPU: Asus strix rx 470

      Motherboard: Msi H110M Pro-VD +

      Ram: 2x 8gb Kingston HyperX Fury

      PSU: Corsair VS450

      HDD: 2x Seagate Barracuda (500Gb; 1Tb)

      Network: Asus PCE-N15 Wireless-N