9 Replies Latest reply on Jul 2, 2018 12:43 AM by ax7

    AMD HD8750M update fails, Windows 10 64bit, Lenovo G510

    zippoex

      Hi guys,

      I recently changed from my old HDD to a 256 GB SSD, Did a clean Win 10 pro, 64 bit install, installed some basic software and now wanted to update to the latest AMD drivers before installing some games and applications that will require more than the intel graphic chip.

      Via Windows Update/if checking in the device manager, it says the latest driver was installed, which is not the case. The driver version installed is 15.200.1050.0 (30.06.2015) which is also the version that appears on the Lenovo Support Website.

      However, there are several newer versions (17.1.2 , from yesterday).

      When I try to manually install the latest driver, windows will stop displaying any changes (picture freezes) and ignore any input from mouse or keyboard. After power off and reboot windows fails and I have to restore a previous saved version.

      Tried to uninstall/reinstall in safe mode as well but nothing seems to work. Help please? Anyone?

      PS: It worked with my HDD in the otherwise same Notebook.

       

      Similar problems that I found but NOT the same:

      AMD Radeon HD 8750M not compatible with Windows 10

      Can not install driver on win 10 HP probook 450 G1 amd HD8750M.

       

      EDIT: When I try to install the chipset driver (optional download when selecting the driver) the software returns "error 182" and is unable to detect the AMD graphic card. Just wanted to let you know...in case it helps.

        • Re: AMD HD8750M update fails, Windows 10 64bit, Lenovo G510
          kingfish

          Do not change the default location for the AMD drivers. It should be on the same drive/partition as the OS.

          Please read Intel/AMD switchable graphics > Laptop graphics update...How to

          Correct AMD drivers for your laptop (choose a full version) > Mobile

          • Re: AMD HD8750M update fails, Windows 10 64bit, Lenovo G510
            d3f

            I found a solution for this problem. zippoex kingfish
            Probably after Anniversary Update there is a issue with ULPS (ultra low power state) and AMD drivers newer than Crimson 16.7.2. It causes a system freeze.

             

            So there are two solutions:

            1)  If you need a longer battery time and ULPS turned on, you should install version 16.7.2 or 16.6.2 ( I also had some issues with 16.7.2 version due to wrong certificate or sth, but generally it works)

             

            2) If you need the latest version of driver you should disable ulps and then install a driver. Normally you can do it by registry modification, by searching for a registry key EnableULPS and EnableULPS_NA and changing it to 0 value. But during the installation of new driver it reverts back to the default value and system freezes. So you need to mod the driver and disable ULPS by default.

             

            WARNING! It helps me, but I am not responsible if something will go wrong. You do it on your own risk!


            - Find your hardware identifier at Device Manager -> Graphic cards -> AMD Radeon (your card model) -> Details -> hardware identifier
              mine was something like that: PCI\VEN_1002&DEV_6606&SUBSYS_XXXXXX

            - Unpack drivers and find a file C:\AMD\Non-WHQL-Win10-64Bit-Radeon-Software-Crimson-ReLive-17.1.1-Jan16\Packages\Drivers\Display\WT6A_INF\C0310456.inf

            -  Open the file and find you identifier in [ATI.Mfg.NTamd64.10.0...14310]. You should match a proper line for example mine was "%AMD6606.1%" = ati2mtag_R502DS, PCI\VEN_1002&DEV_6606" note the part "ati2mtag_XXXXXX", so mine was ati2mtag_R502DS
            - Now the most important thing is to find the part with config of your graphic card model. Just match your identifier, mine is: [ati2mtag_R502_SoftwareDeviceSettings]
            - Under this part find the lines:

                
                 "HKR,, EnableUlps_NA,      %REG_SZ%, 1"

                 "HKR,, EnableUlps,      %REG_DWORD%, 1"
            - Change the values to 0 and save the file.

            - Alternatively, you can search and change all the values 'EnableUlps' and 'EnableUlps_NA' in this file

            - Probably a driver installation will fail, so you should temporary disable 'driver signing' in Windows settings, before. If you dont know how to do it look at this https://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_devices/how-do-i-disable-driver-signature-enforcement-win/a53ec7ca-bdd3-4f39-a3af-3bd92336d248?auth=1

            - Install the driver and restart the PC. Now it should work fine without freezes on latest drivers.

             

            PS. I was searching for this solution for a few moths, so I hope it helps other user. Maybe it will be a good idea to pin this post somewhere.
            PS2: I hope that AMD will FINALLY FIX this issue!!! It looks that no one cares about it!!!

            2 of 2 people found this helpful