AnsweredAssumed Answered

Games not running on dedicated GPU

Question asked by willyfisch on Mar 21, 2016
Latest reply on Mar 23, 2016 by willyfisch



The game I'm playing only runs on my laptop's iGPU, even though I set it to High Performance. Is there any way to force it to be run on the dGPU or in Crossfire? The iGPU throttles to 300Mhz because of the TDP limit, which results in bad performance.

I also tried both dual graphics enabled and disabled, no difference.

APU: FX-8800p (15W)
dGPU: M360

OS: Win10 64bit

Driver: Tested with both, newest WHQL driver and now current beta (16.3.1)

Game: Age of Wonders 3 (aow3.exe)


Thanks for the help