4 Replies Latest reply on Mar 10, 2016 3:01 PM by ricardozf

    Windows 10 and DVI signal problem (multiple monitors)

    ricardozf

      I've found a lot of threads about this problem but none with a real solution.

       

      I have a R9 290 with 3 Samsung 2233rz monitors (120hz). Two is connected through DVI-D port (dual link cables) and one through Display Port (DPxDVI adapter). But only 1 DVI and the DP monitor works.

       

      I've tried to disconnect the 2 monitors that works, and I got post screen and the windows logo when loading the OS, but no signal after that, no logon screen.

       

      I'm using Windows 10 Home x64, and Crimson 16.2.1.

       

      Is there any thing I could try to make it work?

        • Re: Windows 10 and DVI signal problem (multiple monitors)
          xeleron

          Is the monitor not working constantly not working on the same DVI output?Keep the DP monitor alive and alternate the DVI outputs and see if anything changes.

            • Re: Windows 10 and DVI signal problem (multiple monitors)
              ricardozf

              I've alternated the DVI outputs and something strange happened. I got post screen on the "not working monitor" but as soon the windows loads, the image shows again on the working DVI monitor.

               

              Case 1

              Monitor 1 (DVIxDisplayPort) - Post Screen > loading screen > working as primary screen

              Monitor 2 (bottom DVI) - Post screen > loading screen > working as second screen

              Monitor 3 (top DVI) - Blank screen

               

              Case 2

              Alternating the DVI outputs:

              Monitor 1 (DVIxDisplayPort) - Post Screen > loading screen > working as primary screen

              Monitor 2 (top DVI) - Blank screen on loading OS > working as second screen

              Monitor 3 (bottom DVI) - Post screen > loading screen > blank screen

               

              The only way I got to the third monitor work is disconnecting the other two, and uninstalling the crimson driver, using basic display driver. Then I've tried to install the Crimson driver again, but in the middle of the process the screen went blank.

                • Re: Windows 10 and DVI signal problem (multiple monitors)
                  ricardozf

                  I've switched the DP adapter to the third monitor, but no matter what order I plug the cables, the monitors always behavior the same way:

                   

                  Case 3

                  Monitor 1 (bottom DVI) - Post Screen > loading screen > working as primary screen

                  Monitor 2 (top DVI) - Blank screen on loading OS > working as second screen

                  Monitor 3 (DVIxDisplayPort) - Post screen > loading screen > blank screen

                   

                   

                  Found out the problem: the cable of the third monitor.

                   

                  I was not using the original cable, but was DVI-D Dual Link compatible. I've changed to the original and it worked. The problem is the length, is too short to reach the monitor.

                   

                  Now I have to find a longer cable that works. I'm gonna try a Single Link one, since is connected to the display port adapter.

              • Re: Windows 10 and DVI signal problem (multiple monitors)
                ricardozf

                I have just installed the Crimson 16.3 hotfix and tried again with the cable that wasn't working. Now it's fixed the problem!