7 Replies Latest reply on Feb 11, 2016 12:09 PM by toastedtoast

    issue with 15.300.1025.1001 driver

    toastedtoast

      Hello,

       

      I own the 4096MB Sapphire Radeon R9 380X Nitro and recently i updated the driver to 15.300.1025.1001.

      I used the previous version before which was something like 15.11... just the usual previous one.

       

      With the new driver i get FPS problems playing Fallout 4, which I didn't have before. Sometimes the frames drop down to around 20 and in the most ridicoulus places (Inside buildings, directly in front of a wall...)

      I already tried re-installing the old driver, but wasn't able to make it.

      Either the downloads from AMD just start the Auto-downloader which installs 15.300 again or they just don't change/install the driver.

       

      Is there a fix/patch for this?

      If not, can somebody please give me a step-to-step tutorial on how to install older versions of the card driver?

      I run windows 7 home premium by the way.

       

      Thanks in advance.