AnsweredAssumed Answered

MSI Ati Radeon R9 280 - Windows 10 - System_thread_exception_not_handled: Atikmpag.sys

Question asked by mrjari on Sep 1, 2015
Latest reply on Sep 1, 2015 by ar1hur

I'm having problems getting my videocard running after upgrading from a good working Windows 7 to Windows 10 x64.

 

During the upgrade i already got an error, but upgrade went on after an auto-reboot. After upgrade was ready i saw i had a Microsoft Basic Display Driver installed.

 

Tried severall Catalist versions but all of them resulted in a black screen and having to reboot in safe mode.

The autodetect utility says i have a Radeon HD7xxxx series (i have a MSI Ati R9 280 Gaming on a MSI Z87-G45 motherboard).

 

Tried installing displaycard from devicemanager ..... that seemed to be working ....Windows apparently found a working driver ....but wait a minute, it is an unsigned driver, to bad for u. Back to the Basic Display adapter.

 

MSI Ati R9 280 - Windows 10 - System thread exception not handled Atikmpag.sys

 

Last thing i tried was something from an other forum user on this board

Black Screen Problem solved:

 

1. disconnect LAN

2. Install New Windows (e.g. 10 Pro 64 bit)

3. Install the graphic divers by using the Device Manager (Extract newest Catalyst by executing, do not install it, open DM, select GC, select "update Driver", go the catalyst Folder to install the Drivers).

4. The Display will change Resolution and size according to the GC

5. First, the already opened windows (DM,...) will look like frozen and all is shown like a defective window.

Now windows and GC are adapting, which will take some time until all can be shown correctly.

Do not reboot now, otherise the black Screen will appear.

6. Follow already mentioned Solutions: disable ULPS, disable energy savings, enable just 1 Screen

7. Do some more individual Settings

8. After some times you will see the Display and new windows working correctly

9. Connect LAN again, do the windows updates and Installations ...

10. After successful installation the complete Catalyst and the settings at 6. might be installed/changed

 

But now the system goes into some sort of BSOB with the following error:

System_thread_exception_not_handled: Atikmpag.sys

Then a reboot and i'n exactly at the point where i started: Microsoft Basic Display Adapter installed ;-(

 

Uninstalling all AMD display drivers and cleaning registry didn't work out. Installing severall versions of the driver (Windows 7, Windows 8.1, Windows 10). Today i tried the new beta driver ...... every time same results:  System_thread_exception_not_handled: Atikmpag.sys

 

Is there a solution? Or something i should try? Or do i have tot wait for AMD or Microsoft to come with a sollution?

Outcomes