AnsweredAssumed Answered

AMD Drivers not recognising Ultrawide screen resolution

Question asked by clipped.osprey on Jul 19, 2015
Latest reply on Jan 4, 2019 by fellowslongworth

Hello!

 

I recently built a rig with an r9 295x2 and have an LG 25UM55-P as my monitor. On windows, with the latest version of drivers, the computer is not able to recognise that the native resolution of the monitor is 2560x1080 and instead displays at 1920x1080, and I have searched everywhere and cannot find an option to display at the native resolution

 

I installed Ubuntu as well, and by default it is able to recognise the monitor's native resolution with the X Org drivers. When I install the official AMD drivers, it reverts to 1920x1080 and the option for native resolution doesn't exist.

 

On windows, I was using the latest catalyst drivers - 15.7

The monitor is hooked up to the rig via a mini DP -> HDMI connector. I thought this may be at fault, but Ubuntu is able to support 2560x1080, so I ruled it out.

I tried reinstalling the drivers using a clean install. I also wiped the drive and reinstalled windows, still no effect.

 

I even tried a remedy that was suggested on youtube of navigating to the registry file location of the 2D display driver and messing with the DAL******* (I don't remember the filename exactly. I can find out if it will help) to no avail.

CRU was also of no use.

 

I will eternally love anyone who helps me, and maybe even send you cookies if you help me fix it. ^_^ Super Duper Keen To Game On This Rig!!

 

Thank you. Muchos Gracias. Merci. Terima Kasih.

 

EDIT. I also have a laptop with an Nvidia GT555M that is able to support the full resolution of the monitor. If that helps in any way.

Outcomes