AnsweredAssumed Answered

NV_dx_interop{1,2} not working?

Question asked by oscarbarenys1 on Dec 14, 2012
Latest reply on May 24, 2013 by kusmabite

Hi,

*it's nice to see NV_dx_interop1,2 versions shown latest catalyst versions.. I tested some toy code as exposed near end of WGL_NV_DX_interop.txt extension spec .. after not working also I modified for testing using d3d11 interop.. same error.. I can post a repro case but its very simple to describe I can confirm wglDXOpenDeviceNV call works but any call to wglDXRegisterObjectNV fails with same error (I think ERROR_OPEN_FAILED) and it's Nvidia sample code so it should work!.. My system is a AMD 5850, Catalyst 12.11beta11 and windows 8 rtm.. is this extension only 7xxx series supported only? or should I test on windows 7?

 

*Also sorry for using this post for a update but can you share how OGL 4.3 drivers are cooking? would be good if some beta ships altough not "final quality? can expect this year a beta?..

 

*also more suggestions: are OpenGL devs monitoring AMD Linux Valve forum where suggestion is done for

GLX_EXT_swap_control_tear and GLX_EXT_buffer_age extensions..

Outcomes