cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

fatgeek
Journeyman III

Windows won't install after killing my SSD. I think my CPU is bad.

First, some specs:

  • CPU: R7 3800X

  • Motherboard: Asus PRIME B550M-A Wi-Fi

  • RAM: Corsair DDR4-3000 4x8GB

  • GPU: Asus Strix 2070

  • Boot SSD: Samsung 960 Evo 250GB

  • PSU: Antec EAG Pro 750

On Sunday my wi-fi suddenly disconnected while playing a game (Helldivers II). It wouldn't reconnect so I tried a reboot. It hasn't worked since. I have it on a UPS and there wasn't any crazy weather happening.

I put the boot SSD into an enclosure and it was dead. I replaced it (Samsung 980 Pro 1TB).

Here's where things get weird.

At first I got an error "We couldn't install windows in the location you chose. 0x80300024." It seems to be the same issue as the people in this thread  Now I don't get any error at all. It just spins forever.

I did all the troubleshooting with diskpart in that thread but I get I/O errors.

Now I'm thinking it's a bad motherboard, so I get a replacement; the Asus PRIME B550M-A Wi-Fi II. Same issue Both BIOSes were updated to latest (3404 for the old one, 3405 for the new).

I booted into Linux (Ubuntu 22.04.3) and gParted sees the drive, but fails when I try to do anything on it.

I re-made my Windows install USB (22H2 downloaded through the Media Creation Tool) and nothing changed. I made a new Windows USB using an older iso I had (2020H2, I think) and it's the same issue.

For giggles, I threw an old SATA SSD in there and Windows setup doesn't even start properly.

At this point the only hardware still in the system from when it broke are the CPU, GPU, and RAM., and PSU. And the case, I guess.

One thing I've noticed is that everything is very slow. Booting into Windows setup takes a good five minutes. Every step in setup takes at least a minute of hourglass. Same in Linux.

I'm old and have been doing this professionally for 20 years. If it's a bad CPU then it's the weirdest bad CPU I've ever seen. I can't think of how a GPU might cause this issue either.

I took out all but one stick of RAM (and tried another) and that didn't make a difference, I pulled RAM from my Unraid box to test with as well and there was no difference.

I also tried another PSU. I don’t have a spare CPU or GPU to test.

Can anyone else think of anything I haven't thought of?

EDIT: I was able to borrow an RX 570 to test with and the issue persists. I also ran a Memtest86 and it passed. I guess it's the CPU, but I've never seen a CPU fail this way. I can boot all the way into Linux on a live USB and work with the system. It just doesn't let me work with storage. Really strange.

 

0 Likes
7 Replies
misterj
Big Boss

fatgeek, is this W10 or W11? Please do a Clear CMOS then remove all but one memory stick and try booting into BIOS. If that fails, try a different stick and socket. If you get this to work, use Diskpart to Clean All then format it as GPT a try installing Windows. Thanks and enjoy, John.

0 Likes

I did everything suggested. I cleared the CMOS to the point of replacing the entire motherboard. I'm trying W10, but the issue is also occurring in Linux. I'm 99.99% sure my CPU is causing the issue now. 

0 Likes

Open a AMD SUPPORT - WARRANTY Ticket and see if they believe you need to RMA your processor from here: https://www.amd.com/en/forms/contact-us/support.html

Here is your Motherboard's Storage Specs from Asus: https://www.asus.com/motherboards-components/motherboards/prime/prime-b550m-a-wifi-ii/techspec/

Storage
Supports 2 x M.2 slots and 4 x SATA 6Gb/s ports

AMD Ryzen™ 5000 Series/ 3000 Series Desktop Processors

M.2_1 slot (Key M), type 2242/2260/2280/22110 (supports PCIe 4.0 x4 & SATA modes)

AMD Ryzen™ 4000 G-Series Desktop Processors

M.2_1 slot (Key M), type 2242/2260/2280/22110 (supports PCIe 3.0 x4 & SATA modes)

AMD B550 Chipset

M.2_2 slot (Key M), type 2242/2260/2280 (supports PCIe 3.0 x4 & SATA modes)

4 x SATA 6Gb/s ports

Support RAID 0, 1, 10

M2.1 is controlled by the CPU. M2.2 plus the 6 SATA Ports are controlled by AMD CHIPSET on the motherboard.

Not sure if you mentioned that you changed the SATA Cable to the Windows Drive. Maybe it is defective.

Possibly something shorted your original SSD Windows drive and damaged your CPU in the process. Like a Power spike from your wall outlet after a blackout, as an example.

NOTE: From your post you have pretty much eliminated all the major hardware that could have caused your issue except the CPU.

Best way to check the CPU is by either installing another CPU on the motherboard or installing your current CPU on another compatible Motherboard and see if it boots into Windows.

EDIT: Are you able to enter BIOS by any chance?

0 Likes

I doubt there was any power issue as I have the machine connected to a UPS that offers protection. I can get into the BIOS on both motherboards, and I have everything set as I did when it was working. 

Windows is installed on an M.2 SSD, so no SATA cable to swap. I did also try to install to a SATA SSD as a troubleshooting step, but that had the same result. I also tried to install via the second M.2 slot with the same result.

As for an RMA option, I bought the CPU in August of 2020, so I'm sure the warranty has expired by now. 

 

Thanks for the response. 

0 Likes

Thanks for the update.

Really since the processor is out of warranty the only way to verify it is bad is by installing it in another compatible computer or installing a different compatible processor in your motherboard.

You might try you nearest computer repair shop or Best Buy (Expensive) to test your CPU or borrow a CPU from a family or friend.

From my experience, CPUs are pretty hardy and long lasting hardware. But maybe it is just bad luck you got one that didn't last long.

NOTE: I am surprised that the computer even boots up with a possibly defective CPU installed and passes the BIOS Test for the CPU during POST.

Good luck and take care.

0 Likes

Thanks, fatgeek. With that certainty, I would suggest you RMA the processor. Good luck, John.

0 Likes
FunkZ
Forerunner

The Samsung 980 Pro had known firmware issues. It wouldn't be a shock to discover the 960 had similar. Have you updated the firmware on these drives? Have you tried a completely unrelated drive to see if issue persists?

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT