Showing results for 
Search instead for 
Did you mean: 


Adept III

WHEA-Logger 18 - Ryzen 7600x


These errors are appearing frequently in the windows log, I only noticed them after the PC froze completely in a moment, making me have to restart it in a forced way.


Reported by component: Processor Core
Error Source: Machine Check Exception
Error Type: Unknown Error
Processor ID: 2



CPU : 7600x (Temp ~50 celcius)

Motherboard : Asrock x670e Steel Legend (bios 1.11 - last one stable)

Ram : 4x 16gb Corsair Vegeance 4800mhz (but is auto setted to 3600mhz when use 4x sticks)

SSD : 2x Kingston M.2 NVMe KC3000 (1tb and 2tb)

PSU : Seasonic 550w

Windows 10 x64

Complete specs:

Thanks a lot.



I made the Memtest with 4 passes, almost 4 hours to complete and no errors in memory.

Run Prime95 to stress memory for almost 30 minutes and no errors found.

Run Prime95 to stress the CPU for about 30 minutes and so far no errors found.

The event log not showed errors when I made the Prime95 tests above. But out the tests appers this WHEA Loggers...



The Ram was setted to 4800 (4x 16gb) in BIOS because in the 7600x page show the Ryzen 7600 support 5200mhz! But, does not  specify this is only for 2 or 4 sticks, this specs are in 7700x, 7900x pages, but not on 7600x. So, when I booted to 2 sticks, the ram setted in auto to 4800mhz, when I booted in 4 sticks, the ram booted in 3600mhz, so I cheked the 7600x page and seen nothing about 4 sticks, only 5200mhz max, so I setted the ram to 4800mhz, tested with memtest, prime, and everything and no problems, but the windows event viewer showed the WHEA errors (that I only went to see afterwards.)

Now I setted to AUTO in BIOS and its in 3600mhz because the 4 sticks, I'm testing to see if any new errors, first boot with 3600mhz showed the errors, but 1 hours later no more errors, I have to use and test more if this will make anything different.

But 7600x do not specify any limit for max ram speed in 4 sticks, so the max ram speed limit in 7600x for 4 sticks is 5200mhz or 3600mhz (like 7700x) ?



In the little time I`m using the PC, I did not see more errors in event viewer while using the PC.

But every time I boot the computer, when Windows start, I see these errors. Even with 3600mhz auto speeds.

RAM can be the problem? I have to test 2x16 with auto 4800mhz to test.

Or the problem is the CPU?

23 Replies
Adept III

Tested with 32gb (2x 16gb) and default AUTO 4800mhz speed and not errors anymore. This is a ram problem? But the other two sticks I setted to default AUTO - 3600mhz too and have WHEA problems



Tested separately the two 2x16 sticks. And no errors, Tested separately in same slot ( A2, B2 )

Now I will test the 4x16 gb again but with some slot change between them.

First I setted the 2x16gb to dual channel slots A2- B2, and the other stick group to A1 - B1, now I will try to put the same group in A and the other ram group in B.



Setted the ram sticks group to 2X16gb in A, and 2x16gb in B, and WHEA error when start windows, the system start 100%, but in windows event error, this error is showed....

I will test 3 slots to see if the error occurs.



3 slots (3x16gb) in A1 - A2 - B2 and no errors. (auto 3600mhz)

2 slots in A2 - B2 no errors.

I will test: 3 slots in A2 - B1 - B2.



Tested in slots A2 - B1 - B2 and no errors.

So seems the problem only occurs when I have 4 sticks, with 2 or 3 in any slot will work correctly without errors.

When the problem occurs windows take more time to boot than normal.


Now I don't know what to do or where is the problem... BIOS problem? When 4 sticks are in use? Ryzen problem? I can return 2x16gb ram berfore tomorrow, but the problem is not the stick, is when using 4 sticks. sad...



Changed the PSU from a Seasonic 520w for a Thermaltake 600w and... nothing, same problem...


Driving 4 DIMMs is tricky enough even with previous Zen generations, with DDR5 it's even trickier, as you are running very close to the limits of what the memory controller can handle.

Supported speeds drop when running 4 DIMMS of DDR5.  There are articles explaining this.  Here's one:

Intel DDR5 platforms also have similar limitations.



But even in stock / default / auto speed with 4x 16gb in 3600mhz is showing errors,

with 3x16gb 3600mhz = no errors.


WHEA Error occurs in:

4x16gb 3600mhz

4x16gb 4800mhz


No errors:

3x16gb 3600mhz (not tested in 4800mhz)

2x16gb 4800mhz


I wouldn't mind running at 3600mhz, but even at 3600 which is the default, errors occur, how do I know if it's a problem with the CPU or the motherboard or the BIOS?


Thanks a lot.

Adept III

I see another post about chaging ram voltage to 0.05v above, I tryed this and could not set 0.05v, the default one was 1.10 ~ 1.11. Changed to 1.12v and seems the problem was gone.

How this is possible? This could be the cause of the problem?

The 1.12v could damage my system? For the little I research this change is very safe. I have to test more to check if this will work without errors.


I also added the second power cable from my PSU to the CPU (2x 12v), only this add not solved the problem, and possible that one 12v is more than suficient.


Another question, with 1.12v without errors, I can change to 4x16gb to 4800mhz to test, if no errors, 4x16gb at 4800mhz could damage my system?

Adept III

Hmm I observed that when I changed the ram voltage to 1.12v, the CPU voltage auto changed from 1.400v to 1.445v, so, now I don't know if the difference is because ram voltage or cpu voltage.


The errors showed again when restarted the Windows....


 Safe mode the problem does not happen... stranger things..

Adept II

Higher voltage tends to correct many RAM errors. The problem with doing that is that more heat is created that needs to be removed from the RAM DIMM sticks. That can happen naturally without extra equipment so long as the voltage is not raised too much.

So, set the RAM's voltage higher, in small steps per test, until the errors truly stop. If they stop.

As long as the RAM's temperature is still within spec (and the errors do not return), you should be fine and not worry about it anymore.

If the RAM's temperature is outside of spec (e.g., too high), you'll either need different RAM, lower the clock speeds more, or buy a fan to cool the RAM.



I`m using the Corsair Vegeance, its for XMP, but as I will not overclock, I`m using JEDEC.

So, make difference I suing a ram "optimized for intel" in an AMD?

This is what I have:

The default voltage is 1.10v

But, when I check the same DDR5 for AMD, the default voltage is 1.25v (**bleep**???) :

So .. :

  1. is valid to make the test with the RAM in 1.25V?

Thanks a lot.

I will updated the BIOS for lastest Beta build, I have to install the 4 sticks again to test.

I`m thinking to test to install in another HD the Windows 11 to check if this make some difference.



Hmm seems the XMP edition have 1.25v in 5200hz version too, ... '-'

So probably this its just because the overclock.

It's "safe" to test to overclock this 1.10v to 1.25v?

The maximum I tested was 1.15v (but no differences).


Did you check the asrock memory QVL for your board model, and check the memory vendor compatibility for amd systems.

Using unsupported/mixed kits could cause numerous issues. 

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..
Adept II

Good call, goodplay.

I checked Asrock's QVL for that board ( ), and that memory kit is not currently supported on the Asrock x670e Steel Legend.

TheHunter, you definitely should purchase a kit that is supported by your new MB. That link I posted shows a long list of kits that should work with your new board.

I saw this when I bought the card, but since I had the 5200mhz version on the compatibility list, so I bought the 4800mhz one, which is the default frequency without XMP / EXPO, which I figured shouldn't have any problems. And really the kit with 2x16gb works normally, any of them.
It only gives problem when I mix the kits and put the 4 sticks together. There are two kits of 2x16gb.
It may be resolved with an update, but since I can't return all 4 sticks anymore, I can only return 1 kit with 2 sticks, and the deadline is until today, so I requested the return of a 2x16gb kit, let's see if they will to accept.
Then my project to stay with 64gb will have to wait longer. And in the future I sell this kit that I had to keep and buy a new 2x32gb kit.

Adept III

Tested another memory kit in QVL list, and same WHEA error.... (Kingston).

I will change the processor  from 7600x to 7700x to test if this error will occur.

Adept III

Tested another memory, another CPU (7700x) and same WHEA error.

WHEA error is normal?

I have to test if this new memory kit and new processor will stop system freeze I was having....


One second before the WHEA error, event trigger this info:

The process C:\Windows\System32\DriverStore\FileRepository\u0385170.inf_amd64_95217226aa4fb9b0\B384926\atieclxx.exe (ID do processo:2568) has reset the policy scheme from {d93131d9-22c0-42b4-9401-e9ad8bb550cc} to {d93131d9-22c0-42b4-9401-e9ad8bb550cc}


Adept III

Testing 7700x + 4x16gb Kingston. WHEA errors is show when windows start. But I will test if the Windows stop freezing.

(was having random windows freezes with 7600x and 2x16gb Corsair even without WHEA errors...)

Adept III

Tryed almost everything, but the WHEA error when Windows start is keep happening, but this error only is showed in event log and when windows start, system test and everything else does not fire the errors, no bsod.

About windows freezing: so far windows not frozen yet. The only difference is the CPU, was 7600x, and now is 7700x.

but as soon as i installed the 7700x, there was a chpset update, so not sure if that also affected it, but i don't want installing the 7600x again just to test this chipset update. I hope the freezes are gone, they were occurring on the 7600x even with the QVL memories.

If the system works correctly, even with WHEA error at windows start, maybe I would even test the other Corsair memories that are not in the QVL, to make sure that the problem was the processor and not the memories, but if everything continues to work normally, I'm afraid to remove the memories and processors that are working now and then give problem again ahahaha.



WHEA error only in event viewer and only in windows start, it wouldn't be a problem, would it?

Journeyman III

I have a very similar hardware and the same WHEA 18 error message. My system is otherwise stable.

My hardware:

CPU : Ryzen 7700X
MB : ASRock X670E PRO RS
RAM : Kingston FURY DIMM 64 GB DDR5-4800 Kit (KF548C38BBK2-64) (QVL)
NVMe: Samsung 980 Pro 1TB
Netzteil: Corsair RMx Series RM850x (850 Watt)


Because I've already found a few reports with this error message and similar hardware, I suspect it could be due to the combination of the ASRock X670E motherboard and the Ryzen 7000. All the reports I found had an ASRock X670E motherboard.

Maybe it's the motherboard chipset, maybe the CPU has an error related to the chipset.



I was having WHEA error only when using 4 sticks. With 2 or 3 sticks = no WHEA errors.

I wouldn't doubt that the Windows freeze I'm having is because of some ASROCK configuration, right now I'm performing these tests that can be seen here:

Has there ever been a Windows freeze with you?

Thanks a lot.


No my windows haven't freeze yet.

Journeyman III

Same problem:

  • CPU: AMD Ryzen 9 7950x
  • Motherboard: AsRock X670E PG Lightning
  • BIOS: AMI 1.14.AS06 12/15/2022
  • RAM: 4 x 32GiB, Crucial CT32G48C40U5.M16A1
  • OS: Windows 10 22H2


- <Event xmlns="">
- <System>
  <Provider Name="Microsoft-Windows-WHEA-Logger" /> 
  <TimeCreated SystemTime="2023-01-04T09:20:11.2224234Z" /> 
  <Correlation ActivityID="{184a6a37-2ee0-43d5-ba9f-7d34e7d55bd2}" /> 
  <Execution ProcessID="3528" ThreadID="5708" /> 
  <Security UserID="S-1-5-19" /> 
- <EventData>
  <Data Name="ErrorSource">3</Data> 
  <Data Name="ApicId">2</Data> 
  <Data Name="MCABank">29</Data> 
  <Data Name="MciStat">0xffffffffffffffff</Data> 
  <Data Name="MciAddr">0xffffffffffffffff</Data> 
  <Data Name="MciMisc">0xff1fffffffffffff</Data> 
  <Data Name="ErrorType">256</Data> 
  <Data Name="TransactionType">256</Data> 
  <Data Name="Participation">256</Data> 
  <Data Name="RequestType">256</Data> 
  <Data Name="MemorIO">256</Data> 
  <Data Name="MemHierarchyLvl">256</Data> 
  <Data Name="Timeout">256</Data> 
  <Data Name="OperationType">256</Data> 
  <Data Name="Channel">256</Data> 
  <Data Name="Length">872</Data> 
  <Data Name="RawData">435045521002FFFFFFFF030001000000020000006803000004140900040117140000000000000000000000000000000000000000000000000000000000000000BDC407CF89B7184EB3C41F732CB57131FE6FF5E89C91C54CBA8865ABE14913BBD0BBF3B91D20D90102000000000000000000000000000000000000000000000058010000C00000000003000001000000ADCC7698B447DB4BB65E16F193C4F3DB0000000000000000000000000000000001000000000000000000000000000000000000000000000018020000400000000003000000000000B0A03EDC44A19747B95B53FA242B6E1D0000000000000000000000000000000001000000000000000000000000000000000000000000000058020000100100000003000000000000011D1E8AF94257459C33565E5CC3F7E80000000000000000000000000000000001000000000000000000000000000000000000000000000057010000000000000002000000000000120FA6000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000200000000000000000000000000000000000000000000000000000000000000000000000000000003000000000000000200000000000000120FA600000820020B32F87EFFFB8B17000000000000000000000000000000000000000000000000000000000000000002000000020000007CECF3BA1D20D90102000000000000000000000000000000000000001D000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF1FFF0000000002000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF1FFFFFFFFFFFFFFF1FFFFFFFFFFFFFFF1FFFFFFFFFFFFFFF1FFF1B00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000</Data> 





Solved this: BIOS -> Advanced -> CPU Configuration -> SMT Mode -> Disabled.

After this the CPU performance dropped by 1/3 and description says that S3 is NOT SUPPORTED on systems where SMT is disabled... So it seems this is a CPU problem...


For me this problem was happening when 4 ram sticks (unfortunely), with 2 sticks no problem.

But, by my tests, the problem showed to me on Windows start, but never during the normal use. I did not tested with games.


Same... Have you tried to disable SMT?


Not tested the SMT, I will use 2 sticks for now and wait later to use the 2x32gb or 2x64gb sticks. Or a BIOS update to correct this bug.

Big Boss

TheHunter, I suspect your power supply is too small. I have built 1800X to 3970X and used 750 Watt to 1250 Watt PSU. I suggest you consider at least 750 Watt. When Voltages dip all kinds of weird errors crop up. Enjoy, John.