Showing results for 
Search instead for 
Did you mean: 


Journeyman III


I have enabled fTPM and Secure Boot, along with disabling CSM and the W11 Health check does not recognize TPM 2.0

Bios uefi Gpt drive
Motherboard Asrock x570
Chip Ryzen 7-5800x

2 Replies

In BIOS, at least on mine, you need to enable two BIOS Settings. One to enable fTPM on the CPU and another one, which at the moment I forgot, to get fTPM enabled.

Check in Windows and see if fTPM is enabled or not.

How to check if TPM is present on your Windows 10 PC
  1. Open Settings.
  2. Click on System.
  3. Click on About.
  4. Under the "Related settings" section, click the BitLocker settings option. ...
  5. Under the "Status" section, confirm "The TPM is ready for use" to confirm the device has a trusted platform module, and it's enabled.

This Reddit thread mentions that the 5000 series doesn't support fTPM even if it is enabled in BIOS:

Also this  tech site that shows visuals on how to enable fTPM on the 5600x processor in BIOS and how to check it on Windows 11:

EDIT: Check to see if you have the latest BIOS installed. Manufacturers are coming out with Windows 11 supported BIOS versions to sets BIOS for Windows 11 installation.


Cannot allow bitlocker