Showing results for 
Search instead for 
Did you mean: 


Adept II

Ryzen 9 3950X won't allow over 520MHz on all cores

I have had all sorts of issues lately, with multiple reinstalls of Windows 11 and BSODs caused by what I finally realized was Secure boot not letting winload.efi from working. Now that I have it up and running again, I have found that everything is extremely slow and my 3950X is stuck at 0.52 GHz on all cores. I have tried everything from clearing CMOS to updating to the latest BIOS of my MSI Gaming Edge Wifi Mobo. The ONLY thing that helps is, once Windows ever so slowly loads to desktop, I have to open Ryzen Master and disable "prochot" ,which lets it go to its set clock speed. If it's not set to "manual" and is on "default" or "Precision Boost Overdrive", it will run at 520 MHz. Is there something in the MSI BIOS that I can set to fix this? I already tried disabling C States and setting it to "Typical Current" under the CBB section, to no avail. 

0 Replies