cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

EclairOChocola
Journeyman III

Ryzen 9 3900X always max clock speed

Hi everyone !

I see a lot of topics everywhere with the same problem, but none of the solutions (when there is one) works for me.

My configuration :

X570 ROG Strix E-Gaming. Ryzen 9 3900X. RTX 3080. 16 Go RAM (3600). SSD and other stuff.

My CPU is cooled by a brand new AiO Fractal Design Celsius S36+. I also tried Cryorig H5 Ultimate and AiO MSI MEG Coreliquid S280. With thermal paste, Arctic MX-6.

I have this PC since a few years and just recently, after a bios update, I have this issue.

 

The problem : 

Almost all core of my CPU are ALWAYS at full clock speed. And in idle when i do nothing on my PC, the frequency is around 4 GHz. So my CPU is at 73°C.

8e8a839ae3

When I setup the max CPU usage from Windows power management to 15%, I have almost a normal usage of an idle PC. And the temperature is much normal than before (53 °C). But if I set it up back to a higher percentage, the CPU always block at this max value and never to the minimum (5%)

As you can see :

ad1bc5f70f

 

What I already did :

Reset all my BIOS settings. I have a stock BIOS right now.

Clean reinstall AI Suite 3 and Ryzen Master that can affect CPU performance and OC.

Change Windows power management to normal, performance, Ryzen balanced or whatever the issue is the same.

Disabled AMD Performance Boost Overdrive.

Reinstall all AMD chipset Drivers

 

Conclusion : 

I absolutely don't know what to do with that.

I will be glad to hear your propositions

0 Likes
7 Replies
johnnyenglish
Grandmaster

Hi, in the Ryzen Balanced power profile,edit and change CPU minimum state to something like 5 or 10 %

That is what I did on both 2700X and 7950X 

Good luck 

The Englishman
EclairOChocola
Journeyman III

Thanks for your reply  

I just tried that. At the moment i change max CPU usage, the CPU just goes to that load.

eb118a1759

 

Here is the example :

Ryzen Balanced with CPU settings : Min 6%, Max 100%

Normal use with CPU settings : Min 5%, Max 10%

CPU always stuck as max value. You can also see the temperature increasing directly after changes.

0 Likes
Awol
Challenger

Check you bios and see if core boost is enabled if so disable it.

Ryzen 9 5900X / X570 Auros Elite / Sapphire Nitro+ RX6900 XT SE / 64GB Quad Kit Kingston Fury Black 3600MHZ CL16 / EK 360 AIO / RM1000 X PSU

0 Likes

Thanks for your answer.

I did not find any "Core boost" in my BIOS. I disabled all I found about CPU boost or frequency. I have no changes :

I keep the D.O.C.P, I read that the Asus name for XMP. But, even if i Disabled it, The issue is the same.

PXL_20230921_142041836.jpgPXL_20230921_144854714.jpgPXL_20230921_144929576.jpgPXL_20230921_145051178.jpg

I just see something. In windows, like laptop, I can choose a performance and energy settings.

I have the choice between "Best energy save", "Best performance" or "High performance".

I have tested these three options and I see no differences. Just the last one that run CPU at full clock frequency whatever I set in max CPU limit.

 

0 Likes
mitchellhobb007
Journeyman III

The AMD Ryzen 9 3900X is a high-performance processor from AMD's Ryzen 3000 series. It features 12 cores and 24 threads, and its base clock speed is 3.8 GHz with a maximum boost clock of 4.6 GHz.

The behavior you're describing, where the processor is always running at its maximum clock speed, could be due to several reasons:

  1. High CPU Load: If your system is under heavy load, such as running demanding applications or tasks, the processor will try to boost its clock speed to provide better performance. This is normal behavior, and it's a feature called Precision Boost that AMD processors use to dynamically adjust their clock speeds based on workload.

  2. Temperature and Cooling: If your CPU is running at its maximum clock speed all the time, it could be due to inadequate cooling. If the CPU temperature is too high, it may not be able to boost to its maximum speed. Ensure that you have a proper cooling solution in place, and that the CPU is not overheating.

  3. BIOS Settings: In some cases, BIOS settings can affect the CPU's behavior. Check your motherboard's BIOS settings to make sure there are no settings that are locking the CPU at its maximum clock speed. Look for options related to CPU performance, power management, and clock speed settings.

  4. Software Monitoring: Sometimes, software monitoring tools may incorrectly report the CPU speed. It's a good idea to use reliable monitoring software to verify the CPU's actual clock speed. Tools like CPU-Z or Ryzen Master can provide accurate information about your CPU's current clock speed and behavior.

  5. Background Tasks: Ensure that there are no background tasks or processes consuming CPU resources unnecessarily. Sometimes, malware or poorly optimized software can cause high CPU usage.

If you've checked these factors and your Ryzen 9 3900X is consistently running at its maximum clock speed even under light loads, it might be worth contacting AMD support or the motherboard manufacturer for further assistance, as it could indicate a hardware or firmware issue.........

 
0 Likes

Thanks for your answer.

I checked your 5 points and it's all OK for me.

 

I downgrade my BIOS to some older version and reflasj it to the latest.

I select AMD Ryzen Balanced on WIndows power management. And set the power settings to "Best performance" (The middle option). All BIOS setup are defaults one.

All came back to normal, i think :

It's completely different !!2d67bdc863

 

0 Likes

Too fast ! 

It's work only when my task manager is open. If I close Windows task manager, the CPU clock goes to the max frequency !

 

I also tried Cinebench and it's all good. CPU clock goes to the max on full charge and goes to the lowest possible when cinebench is done. But, only if Task manager is open.

I realy don't understand

0 Likes