Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Ryzen 5600G no display. New build from someone new to PC's.

I finished building my computer yesterday after a grueling ten hour job of it. At the end I really thought I'd done alright for myself, despite all worries. Everything was plugged in nicely and I'd managed a surprisingly neat cable job. Then I turn the PC on for the moment of truth: Al LED's turn on, all fans run, all peripherals power on and their LED's function, but no display to monitor through HDMI.

I've tried multiple HDMI cables, multiple ports on the monitor, checking and double checking the RAM placement, checking and double checking all cable connections are secure into the motherboard, updating the BIOS through QFLASH, etc.

It's honestly devastating and crushed my spirits, so I'd really appreciate any help that can be given.

Parts list:

11 Replies
Big Boss

DarknessInferno, please post a list of all parts including your OS. Are you using a graphic card or the IGU? Enjoy, John.


I did post my part list, it's the link right there at the end of my post. I'll just screencap it for you.

No GPU. Intention was to run on integrated graphics once the display actually works.

No OS because I can't get to the stage to install one.

part list.PNG


Thanks, DarknessInferno. Do you have a speaker hooked up, if not, please do. One beep says OK but they do not say more. I suggest you open a support request with Gigabyte and ask them what are the beep codes. Google says:

Gigabyte Motherboard Beep Codes and Meaning

Here are the most common motherboard beep codes from Gigabyte:

1 single short beep means your system is normal.

2 short beeps mean CMOS error

1 long beep accompanied by 1 short beep means a memory error

1 long beep accompanied by 2 short beeps means a graphics card error

1 long beep accompanied by 3 short beeps means an AGP error

Enjoy, John.


No. I don't own speakers as I always use headphones. I take it that won't do? I'll find something cheap with one day shipping on Amazon and grab that.

I have already opened a support request with Gigabyte as well, been waiting on a reply there.

Additionally, my DVI to HDMI cable just arrived. Unfortunately that also does not work, which rules out the HDMI port being the problem.


It is difficult to diagnose problems on this board as, from what I saw in the manual, it has no debug LEDs. You could try resetting the CMOS, and checking the connections for the CPU cable and 24pin, or even reseat the CPU. You mentioned the RAM is correctly slotted and fully seated.

Is your CPU cooler plugged into the correct header?

Some systems will not post if the CPU fan header has nothing plugged in. 

Good luck. It's unfortunate that I can't actually be there to try a GPU in the socket and see if the BIOS on that board comes with some setting that needs to be changed to support an iGPU.

ASRock X570 Taichi, Ryzen 7 5700X, 32GB RAM 3600Mhz, Gigabyte RX 6800 XT Gaming OC, Corsair HX1000 1000 Watt Fully Modular PSU, Win11Pro

Resetting the CMOS worries someone as green as me, but it doesn't seem too hard. Wouldn't I have to immediately update the BIOS again with Qflash even after resetting it?

Reseating the CPU is something I've been considering, even though I really don't think there's any issues with its seating. It's on my checklist to try as I cross off every other option.

Yes, the CPU cooler fan is in the CPU fan slot, as directed from the motherboard manual. All fans on system run and light up.


DarknessInferno, here is kind of speaker I am talking about, really cheap. Clearing CMOS will reset all changes you have made to BIOS but does not change the version. I hope you have not made any changes to BIOS, so it should just get you back to a fresh BIOS. The beep codes you should hear after installing the speaker should help us identify the problem, so I suggest you get one ASAP. Enjoy, John.

EDIT: The speaker (beeper) plugs into the header where the panel connections are made, see your manual.


Understood. Ordered that speaker you listed now.

I have finished resetting the CMOS. No change. Still no monitor display with any cable. I now just finished Qflash updating the BIOS again. Still no dice. Even tried a slightly earlier BIOS version just in case.


Thanks, DarknessInferno. It is hard to say. Hope the beep code saves us there. Please open a support request with your MB vendor. Thanks and enjoy, John.


Installed and ran the speaker. Only one singular beep, which I believe indicates no problems.

So no I'm even more lost.


Sorry, DarknessInferno. Still black screen? Have you tried another monitor? What interfaces are available? Have you tried all of them? Have you opened a support request with the MB vendor. May be time to RMA the board. Please ask them for an RMA. Thanks and enjoy, John.